x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

game module cannot be loaded after compile

As of last night my project worked perfectly with no issues. when I opened it up today I got an error saying 'the game module could not be loaded' or UE4editor-game.dll was compiled with another version and needs to be rebuilt, rebuilding just leading to 'the game module could not be loaded' when the project has loaded to 71% here is the log when this happens: https://pastebin.com/P2nfWAZZ

If I rebuild my projects code (while the editor is actually open) it will compile without issue but in editor nothing has changed. for example I create a C++ class of an actor and give it a UPROPERTY of I can set a Mesh. I compile and then create blueprint from C++ class and then edit and there is no UPROPERTY or anything else I added.

Occasionally the compiler will fail saying one of my class's functions are already defined in another class (I use #pragma once in every class and this code compiled successfully yesterday as is) so the linker could not link (but this happened only a few times). sometimes the compiler will say the target is up to date after making changes and building again. here is what that compile error looks like: https://pastebin.com/tYdeLCHk here is pressing rebuild after that error while changing nothing: https://pastebin.com/LhDcwGFk

I have tried deleting the saved, intermediate and binary folders and rebuilding and generate new VS files and that hasn't worked. Ive also tried all available build profiles too.

I have tried restarting my pc, upgrading to 4.17.2, downgrading back to 4.16.3, creating new projects each time and copying my code into cleanly added new c++ classes and the same issue happens. I also tried with sample C++ code and after compiling, again nothing changed in editor and again after closing the editor the project will not re-open with the error 'the game module could not be loaded'

I have checked if the folder is read only, of which some files in the project directory are. I have tried removing the read-only flag with VS and UE closed and the flag gets automatically re-set, this includes attempts with admin rights via CMD and POWERSHELL, with the same result.

I have changed permissions and owner of the entire drive the project was on.

I have tried creating the project on a different drive.

I have tried all these fixes in every conceivable combination.

Product Version: UE 4.16
Tags:
more ▼

asked Oct 12 '17 at 04:21 AM in C++ Programming

avatar image

Jacob Pozaic
16 1 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question