x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Game Settings Not Saving/Applying

Hello, when I try to change the screen res or FPS limits, anti aliasing etc..it never applies the changes?

I tried to do it in it's simplest form (GetGameUserSettings>ApplyResolution>ApplySettings) and in it's simplest form it still doesn't work. Why?

PS:I am playing in standalone not PIE.

I appreciate any help.alt text

Product Version: Not Selected
Tags:
av.png (400.8 kB)
more ▼

asked Oct 12 '17 at 06:37 AM in Blueprint Scripting

avatar image

timsev7n
98 2 5 8

avatar image Jjman739 Oct 21 '17 at 07:53 PM

I've been having trouble with similar issues, and in looking at your blueprints, it appears that your "Lower AA" piece wouldn't do anything to the game settings because you never use variables from the Game User Settings. The "Lower Resolution" piece doesn't reference Game User Settings at all, but that appears to be intentional based on the "Apply Res" piece.

What I would expect to see running this is that pushing LowerAAButton does absolutely nothing, and ApplyResButton will lower the screen resolution iff LowerResButton was pushed first and the resolution was not already at its minimum, but the string "saved res" will be printed regardless.

So, what you need to do is make the LowerAAButton use a variable from Game User Settings, but if the ApplyResButton isn't working either, then that doesn't solve your problem. You should probably rephrase the question anyways, though, to make it more clear wherein the actual issue lies.

avatar image timsev7n May 08 '18 at 05:06 PM

Thanks for the reply, I think it's a bug in UE4 as using the console cmds worked fine :)

-The prob was that when I went to apply changes to the graphics, nothing actually changed, it basically stayed on the engine settings.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question