x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Google VR plugin enabled build error

Hello,

I was trying to enable Google VR plugin support on an existing sample VR project available in Unreal Engine (4.17.2).

I tried to convert it to a Google VR project by following the steps in documentation. When launching the project it gives me the error (pasted below)

Tried to delete Intermediate, Build folders but it had no effect. VR mode is enabled and if I press Play I can preview it on Windows.

Note: If I disable Google VR plugin then the project packages and runs without any issues on Android.

 [2017.10.11-08.10.33:601][395]LogPlayLevel: Completed Launch On Stage: Cooking in the editor, Time: 8.099942
 [2017.10.11-08.10.35:430][498]LogPlayLevel: Running AutomationTool...
 [2017.10.11-08.10.35:757][516]LogPlayLevel: Automation.ParseCommandLine: Parsing command line: -ScriptsForProject="C:/X.uproject" BuildCookRun -project="C:/X.uproject" -noP4 -clientconfig=Development -serverconfig=Development -nocompile -nocompileeditor -installed -ue4exe=UE4Editor-Cmd.exe -utf8output -platform=Android_ASTC -targetplatform=Android -cookflavor=ASTC -map=/Game/VirtualRealityBP/Maps/StartupMap -skipcook -CookInEditor -iterativecooking -compressed -iterativedeploy -stage -deploy -cmdline="/Game/VirtualRealityBP/Maps/StartupMap -Messaging" -device=Android_ASTC@XXXXX -addcmdline="-SessionId=1807238440B8B047ED91BBADFAF4B3EF -SessionOwner='X' -SessionName='Launch On Device' " -run
 [2017.10.11-08.10.37:847][632]LogPlayLevel: BuildCookRun.SetupParams: Setting up ProjectParams for C:\X.uproject
 [2017.10.11-08.10.37:874][634]LogPlayLevel: Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
 [2017.10.11-08.10.37:874][634]LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Stage Failed. Missing receipt 'X.target'. Check that this target has been built.
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage)
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at Project.CopyBuildToStagingDirectory(ProjectParams Params)
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at BuildCookRun.ExecuteBuild()
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at AutomationTool.BuildCommand.Execute()
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, Dictionary`2 Commands)
 [2017.10.11-08.10.37:875][634]LogPlayLevel:    at AutomationTool.Automation.Process(String[] Arguments)
 [2017.10.11-08.10.37:876][634]LogPlayLevel:    at AutomationTool.Program.MainProc(Object Param)
 [2017.10.11-08.10.37:876][634]LogPlayLevel:    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
 [2017.10.11-08.10.37:876][634]LogPlayLevel:    at AutomationTool.Program.Main()
 [2017.10.11-08.10.37:883][634]LogPlayLevel: Completed Launch On Stage: Build Task, Time: 3.785975
 [2017.10.11-08.10.38:021][642]LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=103 (Error_MissingExecutable)
 [2017.10.11-08.10.38:384][662]LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 0.000080
 [2017.10.11-08.10.38:384][662]LogPlayLevel: BUILD FAILED
 
 [2017.10.11-08.10.38:384][662]PackagingResults: Error: Launch failed! Missing UE4Game binary.
 You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:
 UE4Game <Platform> <Configuration>

I do not see any other error in the log. I can provide more logs but not sure where to enable or find it.

Product Version: UE 4.17
Tags:
more ▼

asked Oct 13 '17 at 03:02 AM in VR

avatar image

N30_WiZarD
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question