Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Chmodding RemoteToolChainPrivate.key for iOS remote builds

I am encountering an error when trying to use the iOS remote build feature. I believe I have everything setup correctly EXCEPT the permissions on the private key that Unreal generated.

Here is the error:


Permissions 0660 for '/cygdrive/C/Users/<username>/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/<ip>/<username>/RemoteToolChainPrivate.key' are too open.

It is recommended that your private key files are NOT accessible by others. This private key will be ignored.

Which is an easy enough error to fix on a Unix system, but I just can't seem to get them set correctly on windows. Here are some things I have tried:

  • running chmod.exe from Engine\Extras\ThirdPartyNotUE\DeltaCopy\Binaries (which is near as i can tell where ssh gets run from)

  • using the linux subsystem for windows 10 and chmod

  • using cygwyn and chmod

  • adjusting permissions using the windows permissions dialog

Does anyone actually have this working?

Product Version: UE 4.17
more ▼

asked Oct 15 '17 at 07:41 PM in Packaging & Deployment

avatar image

5 3 5 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first


I've had the same issue as well and it took ages to figure it out, I was using Unreal Engine 4.18 though. To fix the 'Permissions 0660' error, I followed the instructions on this post: https://answers.unrealengine.com/questions/480092/how-to-launch-code-project-to-ios-on-windows-413.html

Specifically the commands:

 chgrp.exe Users /cygdrive/C/Users/nicho/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/nicky/nick/RemoteToolChainPrivate.key
 chmod.exe 600 /cygdrive/C/Users/nicho/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/nicky/nick/RemoteToolChainPrivate.key

Replacing the directory with your own directory above.

After solving this error I had another one though which I could not figure out:

 LogPlayLevel: UnrealBuildTool: Warning: Identity file /cygdrive/C/Users/myUser/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/192.168.1.xx/myUser/RemoteToolChainPrivate.key not accessible: No such file or directory

This was happening for me because the RemoteBuildTool is set-up to look for the first ssh.exe it finds and then tries to load the cygwin path. If that ssh.exe it finds is a windows native version like in my case, it will run it with the cygwin path which is not a valid windows path and it will fail. To check which ssh.exe is used you can open a terminal and type:

 where ssh

In my case it was returning: C:\Program Files\Git\usr\bin\ssh.exe which is a windows native version. I navigated to that file and changed 'ssh.exe' to something else like 'ssh-1.exe' and it worked (If you run 'where ssh' on a terminal now it should tell you that it can't find the file). Of course now every time I need to use git I have to change it back to 'ssh.exe', so it is not the best solution, but a working solution nonetheless, as I could not find anything else on the forums after hours of trying.

I hope this helped you, let me know!

more ▼

answered Dec 13 '17 at 11:29 AM

avatar image

16 1 1 3

avatar image IslandPlaya Apr 18 '18 at 01:52 AM

This was very helpful, especially the ssh problem which had me stumped. Thank you!

avatar image njivkov Jul 23 '18 at 01:39 PM

If rsync issue that can't find ssh.exe is still bothering you and you have a source engine, you can apply changes from this commit and rebuild UnrealBuildTool and iPhonePackager :


After these changes it should work like a charm ;)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question