Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Paper 2D] - Yellow tinted textures in Tilemap viewport.

I have a strange issue / bug when creating a Tilemap in UE4, version 4.17.1. All textures are tinted yellow in the tilemap window, meanwhile it looks all good in the actual viewport and when testing the game. There is probably a yellow tint because the editor has the tilemap selected but still, Is there a way to turn off/deselect the mapper and this yellow tint? I have seen people with similar issues but there has been no solution. I am wondering if anyone can suggest a solution to the problem? I have little to no experience with Paper 2D, so I don't know if prior versions are affected. Seen from other threads, other versions seems to be affected as well.

Here are links to other peoples threads:



Here are two image of what I am experiencing. (not my images): alt text

alt text

Product Version: UE 4.17
yellowtint.png (22.6 kB)
more ▼

asked Oct 15 '17 at 09:38 PM in Bug Reports

avatar image

43 5 11 14

avatar image Roig Oct 16 '17 at 06:40 AM

Same problem here, Paper2D needs some love...

avatar image EliasWick Oct 16 '17 at 07:28 AM

Thank you for replying! Hopefully Epic can see this and fix it in the next update. It doesn't seem to affect all users, only a couple. If it helps, I have reinstalled the engine but nothing changed. I am using a blank project without any starter content. I have not tried any other combination.

avatar image EliasWick Oct 18 '17 at 06:17 PM

Bump, I know Epic likes to close these if they haven't been active for some time. The bug / issue still persists in my case.

avatar image JJuraszek Oct 20 '17 at 09:35 AM

I have the same problem here man.

avatar image EliasWick Oct 23 '17 at 05:06 AM

I have a friend who is experiencing this as well.

avatar image Roig Oct 24 '17 at 10:53 AM

Maybe we should do a post with ALL the issues / bugs / improvements of Paper2D. Maybe Epic will not ignore us if we do it this way.

avatar image JJuraszek Oct 25 '17 at 08:01 AM

In my opinion, the problem is that there is a layer that makes the tint, because the tileset looks fine but when drawing it becomes yellowish. When you run the game the colours are also good but it is annoying when drawing. So it is a layer we are looking for.

avatar image EliasWick Oct 26 '17 at 07:01 AM

Right... What I don't understand is that they are ignoring this thread completely. They are normally pretty quick on getting back on these sorts of issues.

I'm not a professional programmer, but this bug should be something that would be pretty straight forward to solve.

JJuraszek explained the issue and probably a great solution to the issue.

avatar image EliasWick Oct 30 '17 at 06:24 AM

I have asked the same question as above on Polycount and I am still awaiting answers. Link to Polycount thread

avatar image EliasWick Nov 06 '17 at 10:20 AM

The issue persists... Really, all that I want to know is if this will be worked on? Are there any plans on updating Paper 2D in the coming month, or should I migrate my game to another engine?

avatar image EliasWick Nov 17 '17 at 01:43 PM

This is still an issue as of 2017-11-17.

avatar image EliasWick Jan 15 '18 at 10:14 AM

Still an issue as of 2018-01-15. There must be someone with a solution?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I have found a "Solution" and the cause to the issue we are experiencing. I assume this is something Epic would be able to fix in a short amount of time, if they so desire. The following thread that is covering another topic helped me solve the issue: https://answers.unrealengine.com/questions/542129/how-to-turn-off-the-mesh-highlight-for-skeletal-me.html

The solution: When the engine is opened go to: Edit > Editor Preferences > Viewports > Expand [Look and Feel] and check [Highlight Selected Objects with Brackets].

This will enable Brackets around the selected object, but ensures that the colours will stay true in both the engine viewport and tilemap.

I am using version: Unreal Engine 4.18.2

more ▼

answered Jan 15 '18 at 10:37 AM

avatar image

43 5 11 14

avatar image EliasWick Jan 26 '18 at 09:36 PM

I have created a video showing you how this can be solved! https://www.youtube.com/watch?v=ODvogDILb3c

avatar image phil123456 Mar 09 '18 at 09:53 AM

yes you forgot to mention the option is hidden and one need to click on the arrow in the bottom

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question