x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Spline mesh complex collision missing in packaged game.

Hello,

I'm having problems getting spline mesh complex collisions to work in a packaged game, I dont know if its intended or a bug or if i'm just missing something. I have looked around for solutions but haven't been able to fix it. I can easily reproduce it in a new project in 4.17.

The problem i'm having is I have actor blueprints with spline meshes that are spawned in at runtime. The spline meshes have collision enabled with complex collision. The collision is not working at all after packaging the project.

Some points:

  • It's working perfect in PIE and standalone play modes, but gone after packaging.

  • Simple collision works fine everywhere, but for this I need complex collision.

Steps to reproduce:

  • New actor blueprint with a spline mesh component, manually set end position and tangents to whatever.

  • Set collision enabled and block all.

  • Set mesh to one with complex collision (I used an imported cube mesh with some loop cuts).

  • Manually place the spline actor in a level.

  • Have another blueprint spawn the spline actor in a level.

In PIE and standalone, both the manually placed actor and the spawned one has collision without problems, but after packaging the spawned one has no collision at all.

I've tried many things like adding new spline mesh components instead of spawning actors, setting the start and end of the spline meshes, having collision off and turning it on at runtime etc. Anything that changes the spline mesh in any way breaks the collision for me when the project is packaged.

alt text

alt text

Product Version: UE 4.17
Tags:
screen2.png (764.2 kB)
mesh1.png (507.8 kB)
more ▼

asked Oct 16 '17 at 11:43 PM in Packaging & Deployment

avatar image

Hawksed
1 1 3

avatar image codeonwort Mar 07 '18 at 08:19 AM

I'm also looking for the solution.

I found that spline mesh collision is 'intentionally' disabled in a packaged game. See UStaticMesh::GetPhysicsTriMeshData in StaticMesh.cpp.

It seems modifying the engine code is the only way to go, according to this question: https://answers.unrealengine.com/questions/175321/spline-mesh-collision-missing-from-packaged-build.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question