x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't run game in DebugGame Editor Profile

When trying to launch game from Visual Studio in DebugGame Editor profile, game complains about missing module (ie. UE4Editor-MyProjectName-Win64-DebugGame.dll), even though this module is present.

Happens in both launcher version and GitHub version.

When manually building game module in VS it works in launcher version, but doesn't in Github. In Github version it tells it can't load bunch of engine level plugins. Also happens on Master Branch.

Windows 10 (Fall Creator Update, although happened on Creator Update as well). Visual Studio 2017 (15.4).

Edit:

After some poking around I found:

UE4Editor-Win64-DebugGame.modules Which have:

 {
     "BuildId": "b38437c3-c336-48df-b19d-f76fb45f7c9e",
     "Modules": 
     {
         "ActionRPGGame": "UE4Editor-ActionRPGGame-Win64-DebugGame.dll"
     }
 }

Then looked into log and found

 LogInit: Read version file with build ID 'a9f1a02c-f163-4b87-beaf-63d1561479e6'
 LogInit: Registered custom module enumerator with build ID 'a9f1a02c-f163-4b87-beaf-63d1561479e6'

As you can notive guids are different. For test I replaced guid in .module file with the one in log. After it, ActionRPGGame module was loaded (didn't solved issue with like 50 other modules).

Edit2:

It seems to also not work under Windows 7 and Visual Studio 2015.

Edit3: Temporary workaround. Set BuildId: in Engine/Build/Build.version to some static GUID. Clearly not the intended approach but at least it starts.

Product Version: UE 4.18 Preview
Tags:
more ▼

asked Oct 18 '17 at 10:00 PM in Bug Reports

avatar image

iniside
1.6k 104 97 182

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi iniside,

Thank you for letting us know about this issue. This issue was reported in UE-51347, and has been fixed for 4.18.

Tim

more ▼

answered Oct 19 '17 at 02:24 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question