x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why are the "import" buttons greyed out?

I was trying to import an FBX scene for a client to test it out, a skeletal mesh with animations but turns out it doesn't let me, it seems to be stuck or "insistent" on importing animation and doesn't give me the option to import as skeletal mesh or even mesh at all, then I tried with a different skeletal mesh with no animation, same problem.

I was checking answers and it was supposed to be solved on earlier versions of the engine, currently I am installing 4.12 to re-check if I can import onto that but it will literally halt any progress I can do with my projects if I am completely unable to test them in-engine.

Product Version: UE 4.17
Tags:
untitled.jpg (260.7 kB)
more ▼

asked Oct 20 '17 at 12:40 PM in Bug Reports

avatar image

VanFanel1980mx
1 1 2 1

avatar image PhilsMeatHammer Nov 08 '17 at 10:16 PM

I am having this same issue on 4.17.2 as well. All other solutions online say to edit the EditorUserSettings config file but that solution did not work for me. Were you able to ever find one? This bug has halted progress for me as well, what good is a game without being able to have our main characters? The attached image is for anybody else who may have a solution, here is the problem when trying to import. alt text

avatar image VanFanel1980mx Nov 08 '17 at 10:22 PM

I had to literally redo the whole rigging and export the standalone skeletal mesh without any control rigs, then proceeded to make the animations and export them, not sure what was the problem but is certainly not a great solution, on the other hand if you are trying to import animations and it doesn't let you pick a skeleton (more likely if you are on win10) change your desktop settings to high contrast and see if drop down menus are back, it was a weird glitch present in 4.12.5 and I presume some earlier versions.

avatar image PhilsMeatHammer Nov 08 '17 at 10:33 PM

That's so annoying you had to redo all that. I'm not even trying to import an animation right now, just the mesh with the skeleton and this is the first box that pops up. When I hover over the choose skeleton option, it tells me if I leave it as none, it will make a new skeleton which is what I want it to do. I enabled "animation" and "bake animation" in my export settings in Maya, since that is what the UE docs said to do. Any other way and UE has given me a popup box with the message "failed to import asset." Thanks for your quick response, sounds like I may have to follow the same process you did if nothing else works. I'll let you know if I do figure it out though, in case you come across this problem again

avatar image VanFanel1980mx Nov 08 '17 at 10:36 PM

To alleviate the whole process try to salvage your mesh by exporting it to OBJ or other format and reimport to a new Maya scene, if it is a skeletal mesh you may want to also backup your weight maps and apply them onto the mesh, basically, try to rebuild your barebones mesh and then importing it again onto UE.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question