Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Bug with Skeletal Mesh Import and Mikk TSpace?

Could there be an import problem with Skeletal Meshes in relation to the Normal Generation Method "Mikk TSpace"? The following two screenshots show the same mesh with the same material and scene settings. Both have been imported exactly the same (Import Normals & Mikk TSpace), only once as static and once as skeletal.

Static Mesh:

Static Mesh Import

Skeletal Mesh:

Skeletal Mesh Import

Product Version: UE 4.17
static.jpg (35.3 kB)
skeletal.jpg (37.9 kB)
more ▼

asked Oct 20 '17 at 02:24 PM in Rendering

avatar image

36 2 5 10

avatar image DAkAR Oct 23 '17 at 09:42 AM

I`ve encountered the same issue not long ago. Couldn't find a solution tho. Would be nice if someone finds one.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Fascinating. I've encountered the problem you're describing in the second image many times with my work. There are two solutions: Solution 1) In the mesh import settings, set the Normals import setting to 'Import normals and tangents'. This will import the normals from the source file and not use the Mikk t-space normal compute method.

Solution 2) This is more involved. In your 3D modeling package, either set the renderer to show you the invisible triangles that make up all geometry, or manually triangulate the mesh. The errors you are describing will appear as triangles that follow a zig-zag pattern: /\/\/\/\/. rotate the faces so that all triangles follow a slanted pattern instead, like so: //////. this will fix the problem with Mikk t-space normals.

What I want to know is why this happens and if there's anything to do about fixing it without having to do all that...

more ▼

answered Feb 14 '19 at 11:52 PM

avatar image

75 7 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question