Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to rotate/look camera without holding mouse button down?

ok im at a loss here and cannot figure this out at all. im using the top down template but i changed the controls to 3rd person (bought a marketplace item that was TD). it all works except the mouse axis x/y doesn't free look the camera with out holding down right mouse click. i disabled the mouse interface stuff on the controller but all it does is hide the cursor. any help would be appreciated.

Product Version: UE 4.16
more ▼

asked Oct 21 '17 at 04:28 PM in Blueprint Scripting

avatar image

1 1 3 3

avatar image oldnag Oct 21 '17 at 06:14 PM

here is a gif to see what im on about, you can see i need to press the mouse to rotate https://i.gyazo.com/035abbe173877aa5d04937b5b4dad6ef.gif

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I think this function may help you, assign it to a keyboard button to execute it on runtime and see if it works


more ▼

answered Oct 21 '17 at 06:40 PM

avatar image

266 4 4 5

avatar image oldnag Oct 21 '17 at 06:53 PM

i already tryed that and it doesnt work

avatar image Daher Oct 21 '17 at 07:03 PM

then that is the setup of your input, you need to change how the input works on your project can you post a screenshot of the input setup ?

avatar image oldnag Oct 21 '17 at 07:09 PM

the mouse cursor is allways active when i change the mouse interface to all turn off it only hides the cursor

avatar image Daher Oct 21 '17 at 07:22 PM

Ok, then the problem is the viewport mouse capture, try modifing this settings

alt text

sin-titulo4.png (275.8 kB)
avatar image oldnag Oct 21 '17 at 07:26 PM

my setting are the same, ive tryed disabling stuff and still the same, the marketplace asset im using is the top down multiplayer survival one and ive asked the author to help me but i just get ignored.

avatar image Daher Oct 21 '17 at 07:31 PM

weird, have you tried with Capture Permanently and Lock always on the last 2 settings?? that seems to work for me

avatar image oldnag Oct 21 '17 at 07:34 PM

yea with lock allways and capture perm its still the same. it must be something in this asset that preventing it from doing what i want, just wish the guy would answer me on marketplace forum.

avatar image oldnag Oct 22 '17 at 11:19 AM

anyone have any idea that could help me out?

(comments are locked)
10|2000 characters needed characters left

Hey man, found any answer? It seems i have the same problem...

more ▼

answered Jan 25 '19 at 04:37 PM

avatar image

1 1 1

avatar image 100dollar Apr 01 '19 at 01:03 PM

You should set your input mode to Game Only. Get Player Controller, then set input mode to game only

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question