x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Editor Crashing when trying to load project

Good day everyone! hopefully someone can assist me in resolving this issue. Ironically enough this issue happened right when I was about to actually create a backup for my project, and since it has this issue... i should probably fix it before i do that lol.

My project is using blueprints... however if it is necessary to fix this, i am willing to figure out a way to throw some C++ in there!

So... onto the issue!

I was trying to load my project and it failed to load, and popped up an error message. I tried opening it again, same issue, and then I tried opening a different project to see if it was the editor itself or my first project. The second one opened just fine and could be edited with no issue. After looking at the error log (which i am not great at deciphering) and looking at some forums online I figured out that one particular asset was the root cause of the issue. I renamed it with a .blahblah extension and the project loaded fine, and could be messed around with as usual.

As soon as i try and add the effected asset back into the game and do something with it however... the editor crashes and gives me the same errors (as far as I can see). Here is a snippet of where I am pretty sure where the actual error is;

22-23.44.53:975][ 0]LogOutputDevice:Error: === Handled ensure: === [2017.10.22-23.44.53:975][ 0]LogOutputDevice:Error: [2017.10.22-23.44.53:975][ 0]LogOutputDevice:Error: Ensure condition failed: false [File:D:\Build\++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Engine\Private\EdGraph\EdGraphNode.cpp] [Line: 214] [2017.10.22-23.44.53:975][ 0]LogOutputDevice:Error: EdGraphNode::GetGraph : '/Game/PageWidgets/Book_WidgetSwitcher.K2Node_CallFunction_7654' does not have a UEdGraph as an Outer. [2017.10.22-23.44.53:975][ 0]LogOutputDevice:Error: Stack:

The asset in question is a UI widget, and is the UI widget where pretty much all of everything in the project happens from for the most part... So re-creating this widget and all of the connections associated with it in its blueprint would be extremely time consuming for me.

It looks like my widget does not have a UEdGraph as an Outer ... What in the world does that mean? how do I fix this?

Thanks in advance for any assistance you can give!

Product Version: UE 4.15
Tags:
more ▼

asked Oct 23 '17 at 12:00 AM in Everything Else

avatar image

Last Look Games
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Update: Fixed! Loaded a backup that UE4 had saved and just had to change a few variables! YAY!

more ▼

answered Nov 03 '17 at 04:29 AM

avatar image

Last Look Games
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question