x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Media texture displays as white after version update

Hello!

Just tried out .18 preview 4 in search for the solution of a different problem (scene with more than one 3d Widget is jittery in Gear VR. It helped), and encountered that. Media assets transfered with the project got borked. Reference to the media file is correct, and it was transfered automatically to the new version. I've set texture sampler to "External". Everything looked as it should, but surface with media material turned white, and nothing could change that.

I guess, working solution is to delete old assets and reimport/set up everything from scratch, but... I guess that could be considered a bug.

What I did: 1. Created a .17 Mobile project 2. Imported Media file into Movies folder (and physically copied mp4 file to the folder), fixed local link. 3. Created a Media player with Media texture with that file. 4. Created an Unlit Material with that texture. 5. Set up blueprint command to open it (It played, in GearVR build too) 6. Opened project with .18, checked all links and files, everything is in order 7. Set texture sampler to External to resolve new kind of error

Surface with the material is white in both editor viewport and in the build on the device.

Product Version: UE 4.18
Tags:
more ▼

asked Oct 24 '17 at 04:58 PM in Bug Reports

avatar image

Allottho
87 5 8 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

After upgrading to 4.18, you also need to select the MediaPlayer in your MediaTexture. In 4.17, the MediaTexture was assigned to the MediaPlayer. In 4.18 it is the other way around. We didn't have time to upgrade that setting automatically, so you'll have to do it by hand.

alt text

more ▼

answered Oct 24 '17 at 05:14 PM

avatar image Allottho Oct 24 '17 at 07:29 PM

Ah, I see now! Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question