x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Vehicle Bounding Box is Oversized

I have recently attempted to get a vehicle up and running in UE4, though the issue is is that the Bounds/Bounding Box is WAY too big. The vehicle is a skeletal mesh and as far as I can tell, there is NO way to adjust the bounding box with Skeletal Meshes. While you can however view the bounding box when it is a Static Mesh, you still have no option to edit it.

So my question is, is there a way to actually scale the bounding box for Skeletal Mesh? Because there is no Documentation on anything related to bounding boxes, not even using the search option pulls anything up. It would be nice to know how to actually fix this issue, though without proper information to help me I can't actually do anything about it.

Does anyone know what I need to do to fix this issue?

Thanks

Product Version: Not Selected
Tags:
more ▼

asked Jul 19 '14 at 05:21 PM in Using UE4

avatar image

Freakazoid!
76 6 12 17

avatar image Freakazoid! Jul 24 '14 at 02:08 AM

I take it that no one knows much about how bounding boxes work in UE4 then?

avatar image William Docherty Nov 04 '14 at 12:16 PM
  • for wanting an answer to this. Running into the exact same problem, bounding box is twice the dimensions it needs to be, it's sitting on the floor in the viewer and the vehicle is floating in the air. Even worse in game. Seems to be a commonly reported problem, but I've not seen anyonepost a fix.

avatar image Pierdek Nov 04 '14 at 01:29 PM

Hi, Freakazoid! try find Bounds Scale in your vehicle BP then set it to 0.5.

William Docherty are you telling me that vehicle bounding box affect vehicle simulation? First of all create for vehicle physics asset, then tweak wheels offsets then come back;)

avatar image William Docherty Nov 04 '14 at 11:49 PM

Bounding box shouldn't affect vehicle simulation, but at a guess it's used to place the vehicle on the ground in numerous editor windows (as the box sits perfectly on the ground plane it seems) - which is wrong. Scaling the box won't help with placement as the method is fundamentally wrong. Arguably a cosmetic issue if it works in game - but it makes debugging/visualisation more difficult in the editor.

Tried a bunch of different physics asset creation tests following different tutorials and setting wheel offsets, etc, etc - still can't get it to work properly. Am going to just delete the entire thing and start again.

avatar image Freakazoid! Nov 05 '14 at 12:16 AM

The bounding box does not seem to be a purely cosmetic thing. It actually prevents the player model from getting close the skeletal mesh (this case a vehicle) and with that being the case, the player model is a good two - three arms length distances away from the vehicle (from almost all sides).

I don't know why Epic has a thing such as a Bounding box, but it seems to take the place of the mesh collision when it is a Skeletal mesh. As there is no way to use custom collision models with Skeletal mesh's, it would seem that the engine simply slaps on a very generic, over-sized box for the collision which is (my best guess) then converted into the bounding box.

Otherwise have no clue what else the purpose is for a bounding box.

avatar image William Docherty Nov 05 '14 at 08:04 AM

Ah, not tried other actors against the car yet - I was focussing on the vehicle sim component.

In the physics asset definition, each body has a "consider for bounds" bool under "body setup" in the "details" panel. If you turn some of them off does your bounding box shrink?

I re-oriented my vehicle in Maya with Z Up and exported it to match UE4 coord system, rather than rely on whatever "magic" was going on in the FBX conversion process. This seemed to get the bounding box created to exactly match the physics asset body sizes - which at least makes sense now. TBH - no real idea what's going on & still trying to re-set things up from scratch again.

avatar image MagicBots Sep 17 '17 at 05:21 AM

What worked for me was to toggle on the "Bounds" display in the skeletal mesh editor, and adjust the "positive bounds extension" and "negative bounds extension" fields until the bounds tightly fit around the vehicle. You then need to save, close and reopen the editor for the vehicle to rest on the ground according to the new bounds in the various editors.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question