x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Installation Error for UnrealHeaderTool in Ubuntu 16.04

I tried searching for solutions but it seems everyone who gets this error made the mistake of running as root, I have not. Setup.sh and GenerateProjectFiles.sh run without a problem, but after running make I receive the following output:

 bash "/home/drew/Applications/UnrealEngine/Engine/Build/BatchFiles/Linux/Build.sh" CrashReportClient Linux Shipping  
 Building CrashReportClient...
 Using 'git status' to determine working set for adaptive non-unity build.
 Creating makefile for CrashReportClient (no existing makefile)
 Performing full C++ include scan (no include cache file)
 Using clang version '3.8.0' (string), 3 (major), 8 (minor), 0 (patch)
 Building UnrealHeaderTool...
 Using 'git status' to determine working set for adaptive non-unity build.
 Creating makefile for UnrealHeaderTool (no existing makefile)
 Using clang version '3.8.0' (string), 3 (major), 8 (minor), 0 (patch)
 Using bundled libc++ standard C++ library.
 Using fast way to relink  circularly dependent libraries (no FixDeps).
 Target is up to date
 Total build time: 3.36 seconds (NoActionsToExecute executor: 0.00 seconds)
 Parsing headers for CrashReportClient
   Running UnrealHeaderTool CrashReportClient "/home/drew/Applications/UnrealEngine/Engine/Intermediate/Build/Linux/B4D820EA/CrashReportClient/Shipping/CrashReportClient.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -NoEnginePlugins
 Error: UnrealHeaderTool failed for target 'CrashReportClient' (platform: Linux, module info: /home/drew/Applications/UnrealEngine/Engine/Intermediate/Build/Linux/B4D820EA/CrashReportClient/Shipping/CrashReportClient.uhtmanifest, exit code: CrashOrAssert (3)).
 Makefile:252: recipe for target 'CrashReportClient-Linux-Shipping' failed
 make: *** [CrashReportClient-Linux-Shipping] Error 3
 

I followed the instructions posted here and tried twice with fresh downloads.

Any help with this would be greatly appreciated, please let me know if anything else from me is required.

Product Version: UE Github Master branch
Tags:
more ▼

asked Oct 27 '17 at 05:05 PM in Installation & Setup

avatar image

Dninde
1 1 2 2

avatar image Dninde Oct 27 '17 at 07:19 PM

My google-fu is weak. I found this question just down the page from mine, and after checking through everything mentioned in the comments, found that it was failing at HasNonoptionalCPUFeatures() in the exact same manner.

By changing this:

 #define PLATFORM_ENABLE_POPCNT_INTRINSIC  0

in LinuxPlatform.h I was able to continue compiling.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

This was fixed in 4.18, you can either clone 4.18 branch (not release) or cherry pick this commit.

more ▼

answered Oct 30 '17 at 02:45 PM

avatar image

RCL STAFF
2.7k 59 6 88

(comments are locked)
10|2000 characters needed characters left

$ chown -R user: filepath
$ su user
$ make

more ▼

answered Jan 21 '18 at 12:34 AM

avatar image

WhiteSwordSu
1 1

avatar image WhiteSwordSu Jan 21 '18 at 12:37 AM

Do not use 'sudo' or 'root user'.

avatar image jpc0016 Jan 18 '19 at 05:56 PM

I ran the first line as sudo and everything worked. make failed when I originally omitted sudo.

My OS is Ubuntu 18.04.01 I'm using Unreal Engine 4.21

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question