x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE Cannot access visual studio

I tried to create new project twice in UE 4.18 version. When i tried to compile code immediately after creating project, output log said it cannot access visual studio. I also tried to create new c++ class - it doesnt helped. all projects were c++ based.

In 4.17.2 new project everything works well.

There are also 2 strange things only happens in fresh 4.18 project:

  1. When i open c++ file in 4.18 CB, it will load specific file but then it loading another visual studio, so i ended up with 2 VS opened...

  2. When i close and re-open project, it says "modules are missing or built with different version" and asking for re-build... everytime.

As you can see in images, i already have opened and loaded VS when i doubleclicked file in CB, but it also opening second VS... + message about rebuilding fresh reopened project.

https://i.imgur.com/NP3179d.jpg

https://i.imgur.com/Nkhmn9W.jpg

Product Version: UE 4.18
Tags:
more ▼

asked Oct 29 '17 at 04:22 PM in Bug Reports

avatar image

Name368
118 4 14 18

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Name368,

The issue with Visual Studio opening twice when trying to open a code class from the Editor has already been reported in UE-51608.

What is the exact error message that you are seeing when you try to build a code project in Visual Studio?

Tim

more ▼

answered Oct 31 '17 at 06:54 PM

avatar image

Tim C ♦♦ STAFF
18.2k 423 68 286

avatar image Name368 Oct 31 '17 at 08:19 PM

Hi, So i tried to build project in VS and its working... Compile in UE not but build in VS yes. When i clicked build in VS i dont get anymore error about rebuilding modules (which was this error https://i.imgur.com/Nkhmn9W.jpg), so i think we can close this topic because same issue was already registered. Thanks.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question