x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Build failed in 4.18: LNK1181 on UE4-LoginFlow.lib

Hi there,

My project uses Steam Online Subsystem. Compiled/packaged just fine in 4.16, but now in 4.18 I get the following error when packaging for Windows 64-bit:

UATHelper: Packaging (Windows (64-bit)): [4/4] Link MyProject.exe UATHelper: Packaging (Windows (64-bit)): LINK : fatal error LNK1181: cannot open input file 'W:\Games_W\UE4-418\UE-4.18\Engine\Plugins\Online\OnlineFramework\Binaries\Win64\UE4-LoginFlow.lib' UATHelper: Packaging (Windows (64-bit)): ERROR: UBT ERROR: Failed to produce item: W:\UE4_PROJECTS_NEW\MyProject\Binaries\Win64\MyProject.exe

I looked in that folder linked above and there's no UE4-LoginFlow.lib file there. Though there is a UE4Editor-LoginFlow.dll. Looking through previous versions of UE4, I can't find this .lib file there either, but it doesn't seem to cause any errors on those versions. Is it a new 4.18 thing?

I tried verifying my 4.18 install, and tried copying all my assets to a new blank project. Still the same issue. The only plugins I am using are Online Subsystem, OnlineSubsystem Steam, and all the associated plugins for that.

Any ideas on what the issue might be? I'd like to keep this project in 4.18 to take advantage of all the neat stuff that came out with it.

Product Version: UE 4.18
Tags:
more ▼

asked Oct 31 '17 at 06:34 AM in Packaging & Deployment

avatar image

mellowsoft
39 1 5 16

avatar image mellowsoft Oct 31 '17 at 06:45 AM

By the way, if I disable online subsystem completely, the game builds fine. Has something to do with online subsystem framework.

avatar image Vejgaard Oct 31 '17 at 07:16 AM

I got the same thing and trying to debug it now. I will keep an eye on this thread and see if you find how to fix it :)

avatar image mellowsoft Oct 31 '17 at 10:09 PM

Sounds good! Keep me posted if you find a solution...I'm gonna try making a new fresh project tonight and adding online subsystem plugins and see if that works. I'm pretty sure it will still fail though -- I think I am somehow missing a key .lib file here. Next step would be to completely uninstall and reinstall 4.18...

avatar image mellowsoft Nov 01 '17 at 07:32 PM

Just in case you didn't see -- I found a solution, check below!

avatar image mellowsoft Nov 01 '17 at 04:46 AM

If it's helpful at all, here is my full log for the build attempt: https://pastebin.com/wCZ2V6r0

Can't seem to find anything in here that helps my case out much, however...

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Well, I think I fixed it.

I had the plugin "Online Framework Plugin" ticked. I thought it was required by the main Online Subsystem plugin, like Online Subsystem Utils. Turns out, however, it is not required to run Steam, at least.

So I disabled that plugin, restarted the editor, and it all appears to work now. The game communicates with Steam and gets the overlay. Haven't tried creating/joining sessions yet -- gonna do that next. But it appears to build now, at least!

Hope this is helpful to someone who runs into the same issue -- I wonder, then, what is the proper use of Online Framework Plugin, if it crashes builds instantly?

more ▼

answered Nov 01 '17 at 05:11 AM

avatar image

mellowsoft
39 1 5 16

avatar image Vejgaard Nov 02 '17 at 08:18 AM

Thanks for the update. I found that it also was the online framework i had problems with. At some point i did toy around with their party system, but ended up not using it, so i could disable it too. It still sucks not being able to use their party/lobby/loginflow systems, but i guess i will have to look at it again if we choose to use it. For me sessions and Steam online works fine as before the 4.18 update.

avatar image TheJamsh Nov 22 '17 at 03:34 PM

This isn't a fix - many users still require the Online Framework plugin to be active.

Some of my own plugins have dependencies on it, this definitely feels like a bug to me.

avatar image mellowsoft Jan 05 '18 at 12:22 AM

Interesting. Have you found out anything new on the subject? I'd like to be able to re-enable Online Framework to use those features...

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question