Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android packaging build fail - UE 4.18

Hello, I get the build file error below:

UEDeployAndroid.MakeApk: ====31-10-2017 09:51:22====PERFORMING FINAL APK PACKAGE OPERATION================================================ UEDeployAndroid.CreateRunGradle: UEDeployAndroid.CreateRunGradle: Creating rungradle.bat to work around commandline length limit (using unused drive letter Z:) UEDeployAndroid.RunCommandLineProgramWithException: Making .apk with Gradle... ExceptionUtils.PrintExceptionInfo: ============================================================================== ExceptionUtils.PrintExceptionInfo: ERROR: cmd.exe failed with args /c "D:\Stage - kornelis\ARcore\HelloARSample 4.18\Intermediate/Android/APK\gradle\rungradle.bat" :app:assembleDebug ExceptionUtils.PrintExceptionInfo:
(see C:\Users\coolb\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Program+Files+Epic+Games+UE_4.18\UAT_Log.txt for full exception trace) ExceptionUtils.PrintExceptionInfo: ExceptionUtils.PrintExceptionInfo: BuildException: cmd.exe failed with args /c "D:\Stage - kornelis\ARcore\HelloARSample 4.18\Intermediate/Android/APK\gradle\rungradle.bat" :app:assembleDebug ExceptionUtils.PrintExceptionInfo:
bij UnrealBuildTool.UEDeployAndroid.RunCommandLineProgramWithException(String WorkingDirectory, String Command, String Params, String OverrideDesc, Boolean bUseShellExecute) ExceptionUtils.PrintExceptionInfo:
bij UnrealBuildTool.UEDeployAndroid.MakeApk(AndroidToolChain ToolChain, String ProjectName, String ProjectDirectory, String OutputPath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bMakeSeparateApks, Boolean bIncrementalPackage, Boolean bDisallowPackagingDataInApk, Boolean bDisallowExternalFilesDir) ExceptionUtils.PrintExceptionInfo:
bij UnrealBuildTool.UEDeployAndroid.PrepForUATPackageOrDeploy(FileReference ProjectFile, String ProjectName, DirectoryReference ProjectDirectory, String ExecutablePath, String EngineDirectory, Boolean bForDistribution, String CookFlavor, Boolean bIsDataDeploy) ExceptionUtils.PrintExceptionInfo:
bij AndroidPlatform.Package(ProjectParams Params, DeploymentContext SC, Int32 WorkingCL) ExceptionUtils.PrintExceptionInfo:
bij Project.Package(ProjectParams Params, Int32 WorkingCL) ExceptionUtils.PrintExceptionInfo:
bij BuildCookRun.DoBuildCookRun(ProjectParams Params) ExceptionUtils.PrintExceptionInfo:
bij BuildCookRun.ExecuteBuild() ExceptionUtils.PrintExceptionInfo:
bij AutomationTool.BuildCommand.Execute() ExceptionUtils.PrintExceptionInfo:
bij AutomationTool.Automation.Execute(List`1 CommandsToExecute, Dictionary`2 Commands) ExceptionUtils.PrintExceptionInfo:
bij AutomationTool.Automation.Process(String[] Arguments) ExceptionUtils.PrintExceptionInfo:
bij AutomationTool.Program.MainProc(Object Param) ExceptionUtils.PrintExceptionInfo:
bij AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param) ExceptionUtils.PrintExceptionInfo:
bij AutomationTool.Program.Main() ExceptionUtils.PrintExceptionInfo: ============================================================================== Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)

I hope that someone can tell me what goes wrong and how to fix it?

Product Version: UE 4.18
more ▼

asked Oct 31 '17 at 09:05 AM in Packaging & Deployment

avatar image

3 1 2 4

avatar image maxgtp May 11 '18 at 05:34 PM

Hi I'm goku ;).

For those who have errors in GRADLE.

1 ° Deactivate in unreal in the configurations of your project.

2 Delete the INTERMEDIATE folder in the folder where your project is located. It is not necessary to be afraid to delete the project from the pre-saved packaging (FOLDER INTERMEDIATE). This will not delete the base (master) project.

3 Open your project on unreal and see if GRADLE is disabled again. It's ok

4 ° All ready to pack, without errors GRADLES.

5 ° Pay a beer for me, and I will always help :) Welcome to the unreal world, where everything is paid, even the air that your character will virtually breathe on the platform.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

9 answers: sort voted first

I succeeded package with "Enable gradle instead of ant" enabled.

  1. run NVPACK/android-sdk-windows/tools/android.bat

  2. click on "Deselect All"

  3. update Extras/Android Support Repository

more ▼

answered Nov 18 '17 at 01:51 AM

avatar image

158 1 8 10

avatar image BestVeggieburger Nov 27 '17 at 02:50 PM

Hi. I had the same issues as mentioned above and I tried what you (okqi) are saying.



avatar image Ferox Dec 05 '17 at 02:56 PM

Worked thank you!

avatar image jackey7 Dec 18 '17 at 07:05 AM

I am using UE 4.18.2 and also update the lastest Android Support Repository (Rev47). But I still get this error somehow. Anyone know why?thanks

avatar image Raptagon Studios Apr 26 '18 at 12:43 AM

Yeah, same here. I already have Gradle enabled instead of Ant and I have the latest version of Android Support Repository. If someone could assist us, that would be grand.

avatar image TSpartanT Nov 08 '18 at 05:32 AM

Me as well

avatar image UGxSynteX Dec 18 '17 at 07:56 AM

This is the perfect answer! it worked on 4.18.2

avatar image MRVRMAN Dec 28 '17 at 11:55 AM

This fix did the job Thank you :)

avatar image newtori Jan 10 '18 at 05:11 PM

Thank you very much!!

avatar image philolo65 Mar 03 '18 at 08:41 PM

Thank you so much, this is very helpful!

avatar image Widzo Mar 07 '18 at 04:48 AM

Thanks, it worked for me =)

avatar image CD_1 Apr 17 '18 at 09:05 AM

It Work for me, thank you.

avatar image unrealootin Feb 04 '19 at 03:56 PM

I could kiss you right now! My hair turned white worrying about this. Thank you so much!

avatar image DarkLegendx5 Feb 05 '19 at 11:18 PM

where i can update Extras/Android Support Repository

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

try to uncheck "Enable gradle instead of ant" in project settings -> android.

more ▼

answered Oct 31 '17 at 11:23 PM

avatar image

11 1

avatar image UGxSynteX Nov 01 '17 at 11:32 AM

Yeah, I found this "fix" in different topics here on UE answers. But this won't work! giving the same error somehow!

avatar image devilyang Nov 07 '17 at 04:16 AM

How to fix? Please give me a link,thx

avatar image Catherine8687 Jan 30 '19 at 05:42 AM

Unchecking "Enable gradle instead of ant" worked for me

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Within unreal in project settings / platforms / android ..... search android package Name must be composed of two names separated by a period (example: com.mygame)

more ▼

answered May 27 '18 at 09:22 PM

avatar image

6 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

To anybody else experiencing this problem that couldn't find a fix, I had the same error and it turned out to be my firewall blocking it from running.

more ▼

answered Oct 16 '18 at 10:29 AM

avatar image

6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I launched NVPACK/android-sdk-macosx/tools/android and updated the sdk to 28 and it worked again.

more ▼

answered Jan 18 '19 at 02:55 PM

avatar image

6 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi everyone,

Here's what worked for me:

  1. UNcheck "Enable gradle instead of ant".

  2. UNcheck "For Distribution" and Check "For Rebuild".

You may also need to use the sdk manger for isntall all the buid tools for android SDK before that.

more ▼

answered Mar 14 '19 at 09:29 AM

avatar image

16 1 2

avatar image unrealootin Mar 26 '19 at 02:33 PM

Could you provide explanation of what these options do in the background. I am trying to understand how android builds work but there are many options and not a lot of explanation. P. S. thanks for your help.

avatar image uJelleh May 02 '19 at 11:09 PM

This worked :) Thanks man! I think it was the "Full Rebuild" that did the trick.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was facing the same promises, I'll tie the: Enable Gradle instead of Ant And the NDK API Lelel (spcific version or lastest) for: "lastest

and finally I was able to compile the app. good luck

more ▼

answered Jan 28 '18 at 02:21 AM

avatar image

Gelker Ribeiro
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

i tried all the solutions and nothing happened

more ▼

answered Feb 11 '19 at 08:45 PM

avatar image

6 1 1

avatar image DarkLegendx5 Feb 13 '19 at 05:02 PM

i have a problem packaging my game. on gradle and jdk i created a game and solved many problems before and i was packaging my game many times seccusefully and when i tried to install a plugin . Visual studio didnt want to work with ue4.19 so i downloaded ue4.21 and upgraded my project to this version but i had a problem 3 weeks ago and i didnt find any solutions in the internet so please keep reading because. you may have the solution when i try to package my project an error shows up and it is : Log : https://drive.google.com/…/1D2JAgCODYNTbrnSdjd34vhQ8E…/view… Picture of Log : https://imgur.com/a/vWYlo3q but whene try to ucnheck "enable gradle instead of ant" another unsolved error shows up and it is : Log : https://drive.google.com/…/158UA9R5MXeTeQUcQdwReYeTVs…/view… picture of log : https://imgur.com/a/1j8stpY i really tried everything i reinstalled codeworks 6 times and i deleted intermediat and build folders in the project and i updated the rxtra things on SDK tools and i tried many solutions but nothing work and i really need to publish my game but this error slowed me down around 3 weeks now and this is a picture of the settings : https://imgur.com/a/FuupPLw another thing :if i didnt find any solution at least i want to know what to do to make visual studio work on ue4.19 because i have an older version of the project and i need to compile it to make it works

avatar image mightyenigma Feb 13 '19 at 05:47 PM

You may want to start your own new thread/post since this one has already been resolved. Also, have you tried creating a new project in a newer version of UE4 and migrating your project into it?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Noting working. All though it work few days ago. I just unchecked gradle deal but now not even that works. Deleting intermediate and saved doesn't work either. Updating all the tools and platforms and updating repositories nothing working. Wow what a cool program. lol

more ▼

answered Jun 13 '19 at 02:27 AM

avatar image

124 12 23 29

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question