x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shaders compiling forever and no material rendered in the editor

Good day. Some days ago, i mistakenly terminated the Unreal Engine 4.18 startup process at 45%. After that, whenever I launch the engine, it shows in the lower right corner a dialog box saying "Compiling Shaders" with a warning exclamation mark at the left. Thousands of shaders are compiling without end, apparently. I left the pc (Win 10) on for several hours with the Engine running, but nothing changed. For this reason, no material is rendered in the Editor. And, for the same reason, building the lightmaps or the whole project results in an apparent lock of the Engine (or at least if I wait for some hours, nothing happens). I've tried restarting project from scratch, deleting the project and complete reinstallation of the Engine, and also complete deletion of the engine folders before reinstallation. Nothing helped. I'm completely halted.

Please help. Thanks in advance for the assistance

Product Version: UE 4.18
Tags:
more ▼

asked Oct 31 '17 at 03:54 PM in Using UE4

avatar image

Clockmaster77
6 2

avatar image OkanAgca7 Mar 21 '18 at 09:43 AM

Any update on this issue? I now have the same problem and completely blocked because of it.

avatar image HellCommanderFSG Mar 14 '19 at 10:56 AM

The same thing I catched now. I created almost empty project from c++ tps template, made custom character mesh with simple animation and no materials. Then I tried to find project binaries, package project for Linux, but found nothing changed. Finally when I clicked the Launch button, UE starts to build something and then I saw message "Compiling shaders " witha number over 4000. This process still runs now after about 1h of waiting. But there is a noticeable progress: only 3K shaders left =) The same thing occures once before, when I opened a project and UE started to rebuild project due to some version mismatch. That time I killed its process but then UE becomes crashing at the start.

avatar image HellCommanderFSG Mar 14 '19 at 11:18 AM

upd: 20minutes left and UE shows "Compiling shaders 3900". Have no any idea, what it is...

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question