x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dedicated Server Doesn't Load Any Map

This is as far as the log gets:

alt text

I've tried everything I can think of. I've tried a lot of different ways to try and get it to load a map, but I think there's something wrong before that point, because it's not indicating that it's loading ANY map. There's no indication that anything is even wrong, but the log will sit there and do nothing until I kill it. I have no idea what is even wrong, and don't know where to start looking.

Product Version: UE 4.16
Tags:
more ▼

asked Nov 01 '17 at 07:21 PM in Packaging & Deployment

avatar image

Apophix
6 1 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you go to: Project Settings / Maps and Modes / Server Default Map - what do you have there? Also check if you have that map in packaging.

more ▼

answered Nov 01 '17 at 08:43 PM

avatar image

Flash7
839 9 17 29

avatar image Apophix Nov 01 '17 at 08:56 PM

RP_Downtown is the map it should be starting: alt text

This is the cooked server's Content/Maps/ directory (I believe this means it is being packaged correctly?): alt text

avatar image Flash7 Nov 01 '17 at 08:59 PM

but have you included it in packaging? (are you running a packaged game on a dedicated server?)

avatar image Flash7 Nov 01 '17 at 09:01 PM

alt text

avatar image Apophix Nov 01 '17 at 09:12 PM

Ah okay I see. Yes, I have done this. alt text

avatar image Apophix Nov 01 '17 at 09:11 PM

I'm not too sure what that means, I've built the engine from source, built using Development Server config in VS, then I used this command to do... something: Engine/Build/BatchFiles/RunUAT.bat BuildCookRun -project="TotalImpact/TotalImpact.uproject" -noP4 -platform=Win64 -clientconfig=Development -serverconfig=Development -cook -server -serverplatform=Win64 -maps=AllMaps -noclient -compile -stage -archive -archivedirectory="C:\DED\TotalImpactCooked"

I've also tried it using the editor, going to the Project Launcher window and setting it up there, same result. I followed this guide to get to this point:

avatar image Flash7 Nov 01 '17 at 09:24 PM

I also use batch files to build server (linux) and client (windows) at the same time. The only thing that I do not have is: -maps=AllMaps

 cmd /k c:\Unreal\UnrealEngine-release-4.17\Engine\Build\BatchFiles\RunUAT.bat ^
     BuildCookRun -project="c:\GameArtists\Unreal\D1M1Arena\Unreal\D1M1Arena.uproject" ^
     -nop4 -build -cook -compressed -stage ^
     -noclient -server -serverplatform=Linux -serverconfig=Development ^
     -pak -archive -archivedirectory="c:\GameArtists\Unreal\D1M1Arena\Unreal\Build " ^
     -utf8output
 
avatar image Apophix Nov 01 '17 at 09:37 PM

I removed that from my batch file, ran it again, still same result.

avatar image chiefGui Apr 20 '18 at 06:14 PM

Hey @Apophix,

have you found a solution to this problem? Am facing exactly the same situation.

avatar image evandropaulino Sep 16 '18 at 04:33 PM

I'm with this problem also. With 4.18 dedicated server was created correctly. With 4.20, map don't load and server is not listening for connections

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question