Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Is it possible to make 3d UMG widgets never get occluded?

I've got a couple widget components, which serve as UI, parented to the user camera in VR.

  • They ignore the pitch of the camera so the player has to look up or down to seem them.

  • They are located a certain distance away from the camera so the player doesn't feel all caged in. Because of this offset, they'll clip through world geometry though.

Is there any easy way to make it so they never get occluded? I just want them to always be visible unless I hide them myself.

I tried to move them within the player's collision capsule, but making it so they don't clip out I have position them too close for comfort.

Product Version: UE 4.17
more ▼

asked Nov 02 '17 at 05:43 AM in Blueprint Scripting

avatar image

352 35 36 56

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first


  • find this material in the engine content: Widget3DPassThrough

  • duplicate it and move it to your project.

  • open the material and Disable Depth Test in the advanced part of the Translucency tab

  • assign this material to your widget component

more ▼

answered Nov 02 '17 at 10:08 AM

avatar image

13.7k 74 25 57

avatar image kusokuso1 Nov 13 '17 at 01:22 AM

I apologize for not having seen this sooner. Followed your steps, and it worked perfectly the first time. Thank so much for your time, Everynone.

Sorry if this had already been covered somewhere. Fwiw, I did search around for about 30m~1h before posting.

Thanks again!

avatar image Everynone Nov 13 '17 at 08:07 AM

No worries, happy to help!

avatar image Sean Maxhell Dec 12 '18 at 10:19 AM

Cool, but now I have the problem that the WidgetInteraction ray is not render on the menù, but behind that.

avatar image kusogaki77 Dec 13 '18 at 01:37 AM

@Sean Maxhell The widgets I applied the pass through material to were non-interact-able. I've never done that before, so I don't know how to help. I'd suggest you make a new thread for your issue (or maybe go to the UE4 Slackers discord and ask the people in the VR group), that way you'd get more visibility, because my title doesn't really detail your issue.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question