x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem saving to Android. Manifest and maxSdkVersion="18"

After I updated my project on UE4.18, there were some problems. As soon as I understood the packaging of Gradle, I found that I do not have save jobs in a packed version. Next, I found that the new version defaults to

uses-permission      android: name = "android.permission.WRITE_EXTERNAL_STORAGE"      android: maxSdkVersion = "18" /

Because of this, the engine can not save the game. The official Android website says that the application can modify files in its folder without the need to enable the resolution for SDK versions >=18. I think that the engine saves the files not in the application folder, and can not access.

I was trying to set up permissions with this: https://forums.unrealengine.com/development-discussion/android-development/110935-android-permissions-problems?138161-Android-Permissions-Problems= Nothing came of it. Perhaps there is another way? Perhaps there is a way to change the save folder to Android? I think the easiest way is to change the manifest file and cut it: "android: maxSdkVersion ="18"".

Product Version: UE 4.18
Tags:
снимок.png (14.8 kB)
снимок.png (22.0 kB)
снимок.png (308.5 kB)
more ▼

asked Nov 02 '17 at 09:46 PM in Packaging & Deployment

avatar image

Rusel2050
68 1 7 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The problem was solved by including "Use ExternalFilesDir for UE4Game files" in the project settings

more ▼

answered Nov 03 '17 at 01:16 AM

avatar image

Rusel2050
68 1 7 11

avatar image DarkBouffeur Jul 18 '18 at 09:50 PM

Thank you so much for this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question