x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.18 Modules not found or build with different engine version

Update [1]:

  • Using Visual Studio Community 2015 - Update 3

Update [2] - Using Visual Studio Community 2017 - 15.4.2 does not make a difference.

Update [3]:

  • Added visual image of what has changed and might cause this problem:

4-18-binaries-issue.png

====

What:

  • Error about Modules not found or build with different engine version

  • Project is created from Blueprint (Empty Project) and added a C++ class to it.

  • Our team uses version control and I have excluded (.modules, .target and .pdb)-files from version control, since we did not need it for every change (only programmers have visual studio installed).

When:

  • Starting up ProjectName.uproject with only Binaries/ProjectName.dll

  • No .modules, .target or .pdb files (also in Plugins folder which is not shown in example project).

Expected:

  • To open uproject without asking to compile source project.

====

I have created an example project in how to reproduce this issue:

  • Clean (contains no additional .modules, .target or .pdb files, only .dll)

  • Clean_with_binaries_modules_target (contains .modules, .target and .pdb in Binaries folder)

Tested this out in 4.16, 4.17 and it didn't gave me this message.

Download link to MyTestProject.zip

Product Version: UE 4.18
Tags:
more ▼

asked Nov 04 '17 at 12:29 PM in Using UE4

avatar image

Jeisu
20 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi!

We have the same workflow and we also had a similar problem.

We solved it, by adding UE4Editor.modules to Binaries folder in our project (to Binaries for Plugins folders too), after that our artists and designers succesfully run editor.


Project/Binaries

alt text

Plugins/Binaries

alt text

more ▼

answered Nov 08 '17 at 10:44 AM

avatar image

Shepik
66 10 7

avatar image Jeisu Nov 08 '17 at 12:08 PM

Hello Shepik,

That makes sense hence why I have found out when excluding all the files except .dll it reports the message.

I am currently checking out with only .DLL & .modules included in our project and will get back when I know more (including CI-builds, Continue Integration builds).

avatar image Jeisu Nov 09 '17 at 10:16 AM

Hey Shepik,

So far this has been working.


Including .modules files in your binaries works.


Visual Studio does not modify .modules if the DLL is not missing, which is a plus for version control.

I can continue get our 4.18 project to be stable again due new errors!

Thanks y'all.

avatar image Chibey Nov 18 '17 at 08:46 PM

Hey Shepik, how would I go about this if I don't have a "Binaries" folder? I was .git ignoring it so it wasn't in my project folder. I tried not ignoring it and rebuilding my project but the "Binaries" folder still doesn't come up. What should I do? Thanks so much for your answers.

avatar image theonecalledtom Mar 01 '18 at 07:34 PM

go to the folder and "git add filename.ext -f"

Would suggest making sure you git ignore the pdb files, or are happy with having them in git (use lfs).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question