x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No Compiler was found

Hi,

I've been using unreal for a bit and decided to buy the course. I've been having a problem with unreal:

alt text

A few notes:

  • I used UE4.18 before and didn't encounter this problem.

  • I tried to use CLion Integration at a certain point because I am not very fond of VS.

  • As part of previous point I "downgraded" to UE 4.17.2

  • Until this point I had been using VS 2015.

  • Ever since this point I have had the same problem, requesting VS 2017 even though I have it already.

What I tried:

  • I tried to uninstall VS 2015 & 2017 completely and install VS 2017 using UE4.

  • I tried to re-install UE4.18.

  • I tried to install all the Win SDKs (10 & 8.1).

  • I tried opening new projects.

I am genuinely stuck at this point, and would love some assistance with this. Thank you!

Product Version: UE 4.18
Tags:
capture.png (6.1 kB)
more ▼

asked Nov 04 '17 at 03:46 PM in C++ Programming

avatar image

AonGoltzCrank
16 1 4 4

avatar image jimd667 Nov 04 '17 at 04:05 PM

I know its a stretch but try uninstalling it all once again and then removing ALL the folders for UE4 in the hidden AppData folder on windows. I would also make sure that you have all the windows updates for your machine.

avatar image AonGoltzCrank Nov 04 '17 at 04:06 PM

@jimd667 At this point I'd do anything... Will update soon.

avatar image AonGoltzCrank Nov 04 '17 at 10:33 PM

@jimd667 Didn't work, uninstalled everything, including Epic Launcher, data folder in appdata, all previous projects and possible copies of anything. Installed everything from scratch but nothing changed, still the same error. No pending windows updates either.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Okay, I managed to fix it somehow, this is really an under-emphasized version of how ecstatic I was when I solved it. What I did is the following:

  • Delete E - v - e - r - y - t - h - i - n - g Epic Game Launcher, UE (all folder, including %appdata% one), all VS's (all of them!! search and find all of them (make sure you don't uninstall something important, I have VS 14.0 that is in use in some program so I didn't touch that, only the IDEs (2015, 2017, 2013, etc...), everything that had anything to do with the engine.

  • Install Epic Game Launcher again.

  • (optional) Play a bit of Unreal Tournament and give up after a minute because you suck

  • Install UE.

  • Install VS from UE, and make sure the check the .NET framework, leave everything else as is.

  • Make UE verify the engine by:
    1) Go to Unreal Engine tab in Epic Game Launcher.
    2) Go to Library on the left-hand side.
    3) Click the carret (the arrow pointing down) on the UE version.
    4) Select Verify.
    5) Pray to your deity while waiting for this to finish.
    6) ??? 7) Profit.

Please note: I saw a lot of these types of issues all over the web, a lot of them were either solved with a way that didn't work for me, or just didn't work.

Additional notes:

  1. Not sure if this is the reason that this was fixed but might as well mention it, after installing VS, I took the directory, for example C:\Programs\Microsoft Visual Studio\2017\Community (or whatever directory that you have) and copy it. Now open the run menu and right click on Computer and select Properties, then go on the left-hand side to Advance System Settings, click on Environmental Variables, on the lower half search for something along the lines of VSXXXXCOMMONTOOLS. The value inside of that field, save it somewhere just so you can return it to how it was before in case you need to. Change the value in the field to the location that you found before and add Commons7\Tools at the end, so it'll look like this: C:\Programs\Microsoft Visual Studio\2017\Community\Commons7\Tools. Again, not sure if this is the thing that fixed it, but you might as well know about this.

  2. I have also opened a project from the blueprint blank template and changed the following things:
    Edit -> Project Settings -> Windows (under platforms on the left-hand side scroll down) -> Toolchain -> Compiler Version -> Set it to Visual Studio 2017.
    Edit -> Editor Preferences -> Source Code (under general on the left-hand side) -> Accessor -> Source Code Editor -> Set it to Visual Studio 2017.

Hopefully no one will get as frustrated as I have with this problem.

more ▼

answered Nov 04 '17 at 11:36 PM

avatar image

AonGoltzCrank
16 1 4 4

avatar image jbmpanda Nov 05 '17 at 01:05 PM

I'm having the same problem, can you clarify what you you mean by "install VS from UE". Does this mean launch UE and then install from the error message? I have tried this and it is still not working. I would love to start on the Udemy lessons i've purchased so i would be grateful for help.

avatar image AonGoltzCrank Nov 05 '17 at 01:50 PM

Yes exactly, install the VS from UE meaning launch UE and install VS from the error message. I was in the same boat as you, hope this helps you.

avatar image jbmpanda Nov 05 '17 at 02:11 PM

Reinstalling now... crosses fingers Thank you for the prompt reply :)

avatar image AonGoltzCrank Nov 05 '17 at 02:16 PM

Don't forget to verify UE after installing VS

avatar image jbmpanda Nov 05 '17 at 08:46 PM

Verified after initial UE download, then installed VS 2017, verified UE again. Launched it and still comes up with the error. The only other change i made was to install UE in Program Files (x86), the same place where VS is. (Because previously UE was in Program Files). :( As a side-note, "Additional notes 1", I cannot see a variable named anything like "VSXXXXCOMMONTOOLS" nor a value that looks similar; wondering if this may be the problem?

avatar image AonGoltzCrank Nov 06 '17 at 02:05 PM

@jbmpanda Unfortunately I don't know, the only thing I can tell you is to try again for as many times as it takes, or look for other ways.

avatar image jbmpanda Nov 06 '17 at 05:04 PM

Thanks for all the help anyway!

avatar image AonGoltzCrank Nov 06 '17 at 05:08 PM

If and when you find a fix, add it here, and I'll add it to the solution so that there'll be many types of solutions for people to try!

avatar image Gileez Feb 02 '19 at 06:42 PM

I've spent a lot of time trying to figure this one out (i am trying to compile from source). I dont have a clear answer but once i ran setup.bat again re-running generateprojectfiles.bat worked fine so my 6 hour tip would be: make sure you rerun setup.bat with every attempt you make.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I noticed that UE4 is looking for - at least on my PC - for the following folders where it expects devenv.exe:

v14, C:/Program Files (x86)/Microsoft Visual Studio 14.0/Common7/Tools

v15, C:/Program Files (x86)/Microsoft Visual Studio/2017/BuildTools/Common7/Tools

However, my installations of Visual Studio 2017 are under:

  • C:/Program Files (x86)/Microsoft Visual Studio/2017/Professional

  • C:/Program Files (x86)/Microsoft Visual Studio/2017/Community

There was no devenv.exe under C:/Program Files (x86)/Microsoft Visual Studio/2017/BuildTools/Common7/Tools

So all I did was to rename BuildTools to BuildTools_backup and then copy Professional to BuildTools (they all have similar content). Works like a charm.

How did I out about this? I looked at the Source Code and ran UE4 in Debug Editor mode. In SNewClassDialog.cpp row 1013. Using UE4 4.18.3. FSourceCodeNavigation::IsCompilerAvailable() returned false. It looks up in the registry and what knot. Also tested on 4.19 preview.

more ▼

answered Mar 14 '18 at 10:29 PM

avatar image

BlackDragon
51 3 8 10

avatar image bennyball Mar 21 '18 at 04:08 AM

My file "devenv.exe" is here : C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE

And I have the same problem, I just uninstall everything with Revo uninstaller and I delete everything in appdata folder. I reinstall with the method above but I still got this problem !

What should I do ? :'(

avatar image BlackDragon Mar 21 '18 at 04:07 PM

I suggest you run the UE4.sln in Debug Editor mode and track down the code as mentioned. Step-by-step so that you can see where it fails and what it expects.

avatar image bennyball Mar 21 '18 at 07:22 PM

Solved ! The problem was in :

Edit -> Editor preference -> Source code

and I changed "Visual Studio Code" to "Visual Studio 2017". Then file -> refresh Visual Studio worked ! Then close and reopening UE :)

avatar image vassad2214 Aug 19 '18 at 02:56 PM

Also had this problem - uninstalled/installed everything many times - sometimes worked, sometimes not. But: this one worked, Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Add a dynamic link to whatever your real install directory is, and BuildTools from the C:/Program Files (x86)/Microsoft Visual Studio/2017 tree.

mklink /d BuildTools Professional for a quick fix

more ▼

answered Jun 25 '18 at 04:22 PM

avatar image

angturil
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Also had this problem - uninstalled/installed everything many times - sometimes worked, sometimes not. But: this one from @bennyball worked, Thanks!

bennyball Mar 21 '18 на 10:22 PM Solved ! The problem was in :

Edit -> Editor preference -> Source code

and I changed "Visual Studio Code" to "Visual Studio 2017". Then file -> refresh Visual Studio worked ! Then close and reopening UE :)

more ▼

answered Aug 19 '18 at 02:56 PM

avatar image

vassad2214
0 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

alt text

The error is caused by cannot find IDEPath in regedit, so we need to set it correctly as below(add new string value)

alt text

捕获.png (8.7 kB)
捕获1.png (20.3 kB)
more ▼

answered Mar 07 '19 at 05:10 PM

avatar image

rickeychen
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question