x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

4.18 can't launch on the device when gradle is enabled instead of Ant!!!!!?

i can't launch on the mobile using gradle instead of Ant here is apic of the log

alt text

i can launch it if i disabled gradle

i have accept the sdk license

alt text

just one question is it necessary to fill this configSdk page in 4.18 in order to launch it?

alt text

sorry for my bad english.

Product Version: UE 4.18
Tags:
1.jpg (400.7 kB)
2.jpg (289.6 kB)
3.jpg (222.6 kB)
more ▼

asked Nov 04 '17 at 04:13 PM in Packaging & Deployment

avatar image

Moazahmed123
43 9 14 19

avatar image DarkOathGames Nov 09 '17 at 06:32 AM

Same problem here. Ant works fine, gradle dont :(

avatar image SUMA01 Nov 09 '17 at 09:30 AM

Try after Update Android SDK by using "NVPACK\android-sdk-windows\tools\android.bat"

avatar image tmratwork Dec 13 '18 at 07:14 AM

@SUMA01, it worked, thank you!

avatar image Bartosz Kamol Kamiński Nov 27 '17 at 10:18 PM

Same here. I can make working build in 4.17

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first
more ▼

answered Nov 28 '17 at 03:11 PM

avatar image

andrewtek
31 1 4

avatar image Moazahmed123 Nov 28 '17 at 11:23 PM

it finally worked!!!!! thank.

(comments are locked)
10|2000 characters needed characters left

got the same problem, open the license file in android sdk with notepad, it should have only a key like this 8933bad161af4178b1185d1a37fbf41ea5269c55, but when you accept the sdk license it puts a white line before and have error.

just remove the white line , hope this helps

more ▼

answered Nov 28 '17 at 02:40 PM

avatar image

Carlo Gioventù
6 1

avatar image Moazahmed123 Nov 28 '17 at 03:05 PM

i'v tried this but still dosn't work.

avatar image andrewtek Nov 28 '17 at 03:13 PM

I tried that but it only worked while using ANT. When switching back to Gradle it stopped working.

dixfn7m has an answer that worked for me: https://answers.unrealengine.com/questions/718698/accept-the-license-agreements.html

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question