x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Random and slow AI reaction on NavLinkProxy but correct (no fps lag)

Hello

I have strange results. Simple test AI moving to given target - no problems with normal movement, reaction and behavior tree.

I created smart links based on NavLinkProxy. It working smooth, fast with jump - as expected. Ai jumping in run, with no delay.

Different problem I have with crouch through doors and low ceiling. In my blueprint onSmartLinkReached I have AI should crouch (movement and animation blueprint). Ai crouching without any problems and delay. But problem starts with movement, because Ai stops and waiting (immediately on reach). This is very random time, seconds even over minute, then sometimes walking to NavLinkProxy Destination Point, what is set correct - I have all with debug strings and billboards etc. AI can go through low door without problem when/if moving - no collision etc. Just "thinking" and mostly not moving. Any FPS drops and CPU usage, code is clear.

I tried different movement methods - from Behavior Tree, AI Move To Location..., even Simple Move To Location - this have no influence - always lazy reaction if any. Weird - something it going without any problems.

Here screen:

alt text

  • Ai - bot

  • Green arrows - NavLinkProxy with Smart Link - everything is correct

  • Fire - this is ignited on reached by Ai/bot - destination from Smart Link - is correct (for debug)

  • Sparks on the right - Behavior Tree target to move by Ai/bot (for debug)

As I read somewhere here, this can be connected with some old bug, but I'm not sure.

Any help appreciated!

Product Version: UE 4.18
Tags:
more ▼

asked Nov 05 '17 at 04:58 AM in Blueprint Scripting

avatar image

Vaheva
1.3k 24 25 49

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question