x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Scene capture 2D texture is too dark

So un using the spectator Mode for VR, using the texture to screen Mode. The texture im using is the render target of a scene capture 2d component. The texture is extremely dark, and I cant seem to make It brighter

Product Version: UE 4.18
Tags:
more ▼

asked Nov 07 '17 at 02:28 PM in Rendering

avatar image

dawik9000
21 2 3 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

The culprit is Eye Adaptation aka Auto Exposure in post processing.

Scene capture component resets post processing computation on each frame, because of that Auto Exposure adaptation is not progressing at all and it's permanently locked in minimum brightness value. Note that scene capture even if you do that from same position can't just grab ready pixels from the screen, since this feature is primerly made to capture scene from other location, so it needs to render the scene from 0..... and it litterly start from 0 on every frame and this is where issue sits

Best solution i know so far is simply setting Auto Exposure -> Min Brightness to higher value... effectively this variable becomes brightness of captured scene. But this solution won't fix the issue on every application, aspecially if you relay on 1:1 pixel accuracy, but if you just need to get shot from one location to use it in menu or some monitor in the world, setting this is scene capture component post processing settings should do the job. Either way eye adaptation won't work on captured scene whatever you do because of this.

I trying to find solution for this myself as for what i'm working i can't just change brightness of the captured scene, if any know better solution i would be very thankful. I know some other solution i find suggests changing target gamma of texture target, but if you ask me changing eye adaptation settings gives better accuracy. Setting gamma won't give you 1:1 accuracy either way, setting eye adaptation min brightness at least let you set brightness to be fixed to something more accurate to specific eye adaptation value.

more ▼

answered Nov 23 '17 at 05:16 AM

avatar image

Shadowriver
36.6k 931 169 1111

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

If it helps, we had to set our Post Process Material's Blendable Location to "Before Tonemapping" to fix the "darker color" issue. alt text

more ▼

answered Oct 09 '18 at 06:04 PM

avatar image

justinpatterson
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have increased the 'Indirect Lightning Intensity' to around 12 under the 'Global Illumination' settings in the capturecomponent2d detail panel. Don't know if this ok but solved this kind of problem for me...

more ▼

answered Nov 21 '17 at 01:51 PM

avatar image

zurkdahool
1

avatar image Jackyjae Nov 23 '17 at 04:06 AM

I don't think it works well..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question