x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How do I remove the new background and floor from the Material Editor preview in 4.18?

Hello.

I'm talking about these things in 4.18:

alt text

It didn't have them in 4.17 (and earlier) and they're bothering me. With a white pattern I can't even see the scrolling effect on the shield if I'm looking at it from the top (because of the white floor), and I always have to check it in the Blueprint sphere component that has the material applied to it (where the Viewport window doesn't have these "enhancements"). It's ridiculous. Then what's the preview window good for?

Clicking the "Show" button (next to where it says "Lit") and unchecking "Grid" and "Background" doesn't do anything (well, "Grid" removes the grid, but I want that floor gone, too). I would like to only see the sphere, without fricken clouds and a floor. Is there a setting somewhere that will hide them? A .cfg file maybe? Thank you.

Product Version: UE 4.18
Tags:
screenshot.png (248.8 kB)
more ▼

asked Nov 07 '17 at 11:18 PM in Using UE4

avatar image

Andrei Despinoiu
270 4 9 12

avatar image mattis Nov 08 '17 at 05:23 AM

I'm having the same issue. Can't disable the material editor viewport background (toggling Show->Background on or off does not do anything).

avatar image BarryLegg Dec 19 '17 at 01:34 PM

Having a similar issue here - background is always on in material editor viewport. When I go to switch it off, it says it's already off - hitting the toggle button does nothing.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello

At the top left, open the "Window" list and click on "Preview Scene Settings".

A new tab appears below the "Viewport" next to the "Details" tab. Then simply click on it and in its options disable "Show Environment" and "Show Floor".

more ▼

answered Nov 10 '17 at 09:04 AM

avatar image

PierreGUERIN
21 2

avatar image Andrei Despinoiu Nov 11 '17 at 12:26 PM

Thank you! But it looks like there's a bug.

When I open "Preview Scene Settings" both the floor and the environment sphere disappear. They're already unchecked, and the editor remembers them unchecked. It just forgets to see if they're unchecked or not when opening any new material, and I have to manually open the "Preview Scene Settings" each time, for every material, and at every editor restart. Hotfix incoming?

avatar image darrellquick Aug 25 '18 at 12:49 AM

Ditto, any help?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question