x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

In VR, There are additional hands on the ground, only if I play my Game?

Hello all,

I have a problem I have been ignoring for months now, but I really have to face it now! I have version 4.17.2, working in VR with HTC Vive.

My problem is, that whenever I start playing my game, I see a second pair of hands (additionally to my motion controller hands in front of me) on the ground. In Version 4.16, it used to be just one hand and it wouldnt move at all, but now, having updated to 4.17.2, there are both hands on the ground and they replicate the movements I do with the proper hands - except from that they wouldnt replicate the grap movement - so it cant be a shadow?!

When editing my game in the viewport, I cant see these hands. I have tried to setup a completely new game to find my mistake, and the same is happening in this game.

This might sound as a very weird problem and it is hard to describe, but I don't know how to solve it. The additional hands dont actually look like shadows but it kind of seems like they were. I have already tried to uncheck all "cast shadow" stuff, but it didnt help.

Maybe someone can help me? I would be very thankful !

Cheers, Henrike

Product Version: UE 4.17
Tags:
more ▼

asked Nov 09 '17 at 02:49 PM in VR

avatar image

henrike96
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

It sounds like you are possessing your pawn twice. is there a PlayerStart actor in addition to your MotionControllerPawn? Are you overriding GameMode? Is your actor set to autopossess 'player0'?

more ▼

answered Nov 09 '17 at 03:22 PM

avatar image

salm
164 2 3 6

avatar image henrike96 Nov 09 '17 at 04:12 PM

Thanks for your answer! I hadnt had a PlayerStart actor, but adding one just now did not change anything. And yes I have a GameMode called MyGameMode, inside I edited the Pawn and I changed it in the World Settings - is this what you mean by "overriding GameMode"? I'm back at version 4.16 now, and it is very confusing because while playing, that one additional hand is only sitting right in the middle of the room on the floor, doing nothing.

Maybe you have different ideas? Thank you again already!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having the same problem using a custom GameMode with default player set to 'None' and manually spawning two VR MotionControllerPawns into a Listen-Server-and-Client setup. Searching the project for potential culprits, I realized that I had checked the replication box in the BP_MotionController blueprint in an earlier attempt to get replication working. Once I unchecked it and tested it on both machines using the 'Launch Game' option (can be found by right-clicking on the '.uproject' file), the duplicate hands disappeared.

more ▼

answered Jul 17 '19 at 08:32 PM

avatar image

RONPEPE
1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question