x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Scene Capture with Post Process Mat works only with capture every frame

A Scene Capture component that uses a Post Process material ignores that material when Capture Every Frame is set false

Product Version: UE 4.18
Tags:
more ▼

asked Nov 09 '17 at 06:46 PM in Bug Reports

avatar image

Davision
834 64 106 153

avatar image Jon X ♦♦ STAFF Nov 14 '17 at 07:13 PM

Hi Davision,

I'll need more information to help with this issue. What specifically are you trying to do? Can you provide some more specific steps to reproduce the unexpected behavior, and also explain what you are expecting to happen? Also, screen shots of how you have your SceneCapture as well as your material set up would be helpful.

avatar image Davision Nov 18 '17 at 02:09 PM

I just expect it to render with the post process material like it does when Capture Every Frame is set True. So the steps are: make a Scene Capture setup and set Capture Every Frame false, make any post process material and put it in the scene capture component. See that post process material is not rendered. (This was done in editor)

avatar image Jon X ♦♦ STAFF Nov 21 '17 at 03:42 PM

Here's what I get when I set up a basic Scene Capture with PP material, Capture Every Frame set to False. alt text As you can see, the mesh in the background is rendering the PP material. Like I said, we'll need a lot more information to dig any deeper into this.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue and you have some more information to provide, please respond to this message with a sample project that showcases the issue so that we can investigate further.

more ▼

answered Nov 29 '17 at 09:28 PM

avatar image

Jon X ♦♦ STAFF
913 3 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Have you tried checking the "Always persist Rendering State" option? I think I had a similar problem and this fixed it for me.

more ▼

answered Nov 09 '17 at 09:08 PM

avatar image

LeFxGuy
324 14 12 31

avatar image Davision Nov 13 '17 at 10:54 PM

With that I got another bug where it did not render everything. I just let it capture every frame now, for what I'm currently doing with that it is no problem. Would still be nice to get this fixed at some point.

avatar image LeFxGuy Nov 14 '17 at 08:13 AM

What bug did you get with that option enabled?

avatar image Davision Nov 18 '17 at 02:11 PM

The bug is that it did not render everything. I'm having a top down orthographic setup with foliage on terrain. Most of the foliage is then not rendered.

avatar image LeFxGuy Nov 18 '17 at 03:19 PM

Well, just asking because your original post is related to PostProcessing not being included but for me, using the "Always persist rendering state" option fixes that. Thus I wanted to know, also pls write here if you have solved it or post detailed reproduction steps. because now you are with orthographic setup and foliage etc. This is not included in your original post and could be a whole new bug in itself?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question