x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unfixable variable with invalid type

Pretty severe bug I just found: if you copy/paste a Set node for a blueprint struct from a blueprint in one project, to a blueprint in another project that doesn't have that struct, and then rightclick the Set node and "create variable", the blueprint cannot be compiled and the new (invalid) variable can't be deleted.

Repro:

  • Create a project "Project1"

  • Create a custom Blueprint struct "SomeStruct"

  • Create an actor Blueprint

  • Add a variable called SomeVariable of type SomeStruct to the actor Blueprint

  • Place a Set node for SomeVariable

  • Create a project "Project2"

  • In Project2, create an actor Blueprint

  • Copy the Set SomeVariable node from Project1 and paste it into your blueprint in Project2

  • Right-click on the pasted Set SomeVariable node and select "Create variable 'SomeVariable'"

  • Attempt to compile the blueprint

You can't compile because you get the error "The variable SomeVariable declared in has an invalid type Structure". You can't delete the variable because it's invisible in the variables list. Hope you have a backup because otherwise this blueprint is broken forever.

Product Version: UE 4.18
Tags:
more ▼

asked Nov 10 '17 at 02:02 AM in Bug Reports

avatar image

JoeWintergreen
331 10 20 28

avatar image Everynone Nov 10 '17 at 09:07 AM

While this is clearly undesired behaviour, it does sound like a marginal use scenario. Why would you even try doing that in the first place? xD Structs are so fragile as they are, no wonder this does crazy things.

Nice catch anyway. +1

avatar image khalibloo Feb 05 '18 at 08:16 PM

I just ran into a similar issue with structs. One struct suddenly became unusable (maybe corrupted?) after an editor restart and would not even save. I wasn't copying between projects or anything. I created a similar struct and deleted the first one, replacing its references with the similar one. Variables in blueprint classes that had the struct type suddenly vanished and could not even be deleted. The blueprint classes wouldn't compile either.

avatar image mantic Oct 14 '18 at 07:51 AM

Something similar happened to me in 4.20.3. I made a struct in C++, had it wired in some BPs, then added 2 elements to the struct and compiled. The hot-reload kicked in and one of my variables threw an error saying "The variable test declared in ___ has an invalid type Map of Floats to Structures". The variable "test" now won't appear in the variables list and I can't get rid of it or change it and the app keeps erroring out. :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

If in 4.19.1 you duplicate the BP there is a message that pops up asking if you want to delete the variable, if you delete it the BP will work. I had the same error when I moved 4.18.2 to 4.19.1

more ▼

answered Apr 17 '18 at 05:47 PM

avatar image

QuietInsanity
11

avatar image karmiksundar Oct 14 '18 at 09:03 AM

Thank you very much for the great information buddy :D Gomax TV App

avatar image Steazy Dec 14 '18 at 12:21 AM

Unfortunately this doesn't work in 4.20.3 :(

avatar image HazwanJuhari Mar 12 '19 at 04:26 AM

still works on 4.21.2 All you need to do is duplicate that BP then delete the invalid variable. Then you'll have to delete the original and replace it with the new one.

avatar image DarkWave0 Apr 25 '19 at 09:39 AM

This worked for me too, but I instead restarted the project and I got a notification asking if i'd like to delete the invalid variables. Thanks

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello JoeWintergreen,

We are using a new bug submission form. Please navigate to the link below for more information.

Link: https://forums.unrealengine.com/unreal-engine/announcements-and-releases/1410408-unreal-engine-bug-submission-form

Make it a great day

more ▼

answered Jan 09 '18 at 09:44 PM

avatar image

Rudy Q ♦♦ STAFF
47.2k 545 132 525

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was struggling with this issue recently and i found working solution for me, thought u may still need answer :)

  1. Go to your blueprint and create exatcly same variable (same type and name)

  2. Save blueprint and project.

  3. Restart project Now you should not have the notification that you had launching project before.

  4. Go to BP and delete that variable

  5. Save blueprint and project

  6. Restart project

In my opinion variable was still there, but was not visible (bug). Creating exaclty same variable made it "visible" as it was the same variable.

Engine version 4.21. Solution worked for me :)

more ▼

answered Aug 10 '19 at 10:49 AM

avatar image

Sztrombomper
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question