x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BUG: Planar reflections to do not respect Skylight intensity

In this image, there is a large reflective plane along with a smaller Planar Reflection actor. In the Skylight, the intensity is set to "2", which has the effect of brightening the areas effected by the cubemap reflection, but NOT the planar reflections. Note: SSR was turned off in this example

Expected result- Adjusting Skylight intensity effects Planar Reflections so that it matches other reflection sources

alt text

Product Version: UE 4.18
Tags:
more ▼

asked Nov 11 '17 at 05:47 PM in Bug Reports

avatar image

JohnMakesGames
50 2 3 5

avatar image Lily K ♦♦ STAFF Nov 13 '17 at 06:43 PM

Hello,

I am having some trouble replicating this issue. What are the settings that you have enabled on the larger reflective plane?

Thanks,

Lily

avatar image JohnMakesGames Nov 13 '17 at 11:44 PM

Thanks for your response. The plane is a normal static plane with a metallic material applied to it. Here is a repro of the issue-

  1. Make a new "default" level

  2. Create a material(1 metallic, 0 roughness, mid gray basecolor) and apply it to the Floor already in the scene.

  3. Scale the floor up to 10,10,1

  4. Disable screen space reflections by making an unbound post process volume and setting SSR intensity to 0. This is just so you can see the issue without SSR getting in the way

  5. Delete the SphereReflectionCapture

  6. Set the Sky Sphere to be "Movable"

  7. Add a Planar Reflection actor to the scene on top of the floor and turn off "Show Preview Plane"

  8. Observe that the intensity of the reflections looks similar

  9. Change the skylight intensity slider and observe that the lighting/reflections no longer matches up

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

Thank you for reporting this issue and for providing repro steps! I was able to reproduce this issue and have created a ticket for it which you can track here: UE-52362. If you have any more questions or information about this, please feel free to let us know.

All the best,

Lily

more ▼

answered Nov 14 '17 at 04:05 PM

avatar image

Lily K ♦♦ STAFF
408 2 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question