x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dedicated Server crash at startup, Assertion failed

Hi,

My dedicated server is crashing right after startup and I'm really struggling to find out what the issue might be.

This is the only error message I can find in the logs, but since the line that throws the error is in engine code I'm not sure how to proceed:

 LogWindows: Error: === Critical error: ===
 LogWindows: Error: Assertion failed: IsValid() [File:d:\uengine\ucoral18\engine\source\runtime\core\public\Templates/SharedPointer.h] [Line: 824] 
 
 LogWindows: Error: [Callstack] 0x000000003A733FB8 KERNELBASE.dll!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F31F10D0 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F2C2BDDB CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F2ADC2B8 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F2AB6709 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F3C53FBB CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F381E177 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F3C51271 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F2AA7F26 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F2AB72EA CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x00000000F5DC6137 CoralServer.exe!UnknownFunction []
 LogWindows: Error: [Callstack] 0x000000003D52EF91 ntdll.dll!UnknownFunction []
 LogWindows: Error: [Callstack] 0x000000003D52EF91 ntdll.dll!UnknownFunction []

I have tried and successfully created a a working dedicated server using the Third Person Template and the SteamSubsystem, so my general setup should be alright.

The engine is a locally built binary build based on the 4.18 source version (no changes were made, except the ones required to use dedicated servers).

I'm attaching the logs that were generated, I really hope someone could point me in the right direction as after several hours of research I am pretty hopeless. Thanks!

link text link text link text

Product Version: UE 4.18
Tags:
coral.log (10.6 kB)
coral.log (7.9 kB)
more ▼

asked Nov 11 '17 at 06:49 PM in Packaging & Deployment

avatar image

Kontur
191 6 12 16

avatar image Spiris Jun 20 '18 at 10:25 PM

Looking at your first log your game's executable appears to be pretty involved in the call stack, as all of the plugin modules appear to have already loaded that doesnt seem to be the issue either.
You should try attaching a Visual Studio debug session to the process or loading the .dmp file emitted into Visual Studio so you can check the call stack for what is actually causing the crash. (the logs aren't very transparent). If you have built, cooked, and packaged the server you should also be able to run the dedicated server directly from visual studio by switching the solution configuration in Visual Studio from Development Editor to Development Server.
Happy Hunting,
-Spiris

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

bumping, as this is still an issue.

The server instance launches and runs fine in the editor (when 'UseSingleProcess' is not selected in the EditorPreferences), but crashes every time when packaged with the same error.

more ▼

answered Nov 15 '17 at 03:15 PM

avatar image

Kontur
191 6 12 16

avatar image EndersGame0327 Mar 14 '18 at 06:44 PM

Unchecking UseSingleProcess seems to fix the issue for me, as well as getting rid of all the OnRep stuff in the parent class of the class that is causing the break when you run the editor from VS debugging.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

the same error help plz

[2017.11.12-02.45.13:860][ 0]LogWindows: Error: === Critical error: === [2017.11.12-02.45.13:862][ 0]LogWindows: Error: [2017.11.12-02.45.13:863][ 0]LogWindows: Error: Assertion failed: IsValid() [File:D:\UnrealEngine-4.18.0-release\Engine\Source\Runtime\Core\Public\Templates/SharedPointer.h] [Line: 824]

more ▼

answered Nov 12 '17 at 03:11 AM

avatar image

wangxudong
1 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm getting a similar error. From doing some research, KERNELBASE.dll is not the perpetrator, that's just the unfortunate victim. The perpetrator is obviously your <Game>Server.exe.

In order to properly find the root cause of your issue, I highly recommend you copy over <Game>Server.exe along with the .pbd which will contain the symbols and stack traces for what wrong.

Personally, I got the error when trying to use FModuleManager::LoadChecked to load the GameLiftServerSDK plugin that I added to my Plugins directory. I have seen other threads with similar error messages. This could be a stackoverflow or just improper importing of a library that doesn't exist. I am wondering if your case is similar. This could also be improperly built dlls or libs

Some solutions that have worked for other users is simply deleting the packaged contents and repackaging the editor, server.

I'm still looking for a fix. I'm intending on posting here if I find a solution to my error.

more ▼

answered Jun 20 '18 at 07:25 PM

avatar image

SyedAman
13 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question