Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged Game does not start when using FSimpleElementCollector

Hi there,

when using a static FSimpleElementCollector variable in a blueprint function library (of a c++ project) the packaged project does not launch, and doesn't display any errors / log entries either.


  1. Create 4.18 c++ project

  2. Create a c++ class with a static FSimpleElementCollector variable in it

  3. Package

Product Version: UE 4.18
more ▼

asked Nov 13 '17 at 01:59 PM in Bug Reports

avatar image

1 1 2

avatar image Tim C ♦♦ STAFF Nov 14 '17 at 07:17 PM

Hi AMalhofer,

I tried to reproduce this by creating a new code project in 4.18, added a new Blueprint Function Library code class to the project, and added a static FSimpleElementCollector variable to the class. When I packaged the project and tried to launch it, the project launched successfully.

What template project did you use for your project? What settings are you using when you package? Would it be possible to see the code for your Blueprint Function Library class?


avatar image AMalhofer Nov 15 '17 at 09:13 AM

Hi Tim,

the template project was the "c++ -> basic code", using development settings for packaging. I have attached all content of the "source" folder.


source.zip (3.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi AMalhofer,

Thank you for the additional information. I was able to see what I was missing and was able to reproduce the issue that you described. I have entered UE-52502 to have this investigated further.


more ▼

answered Nov 17 '17 at 02:10 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question