x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Migrating Project from 4.14 to 4.17 looses materials

HI everyone out there,

I have spend a lot of my time working on a big scene with alot of different assets with the 4.14 version of the engine. Now I want to add some stuff with the DataSmith plugin, so I need to upgrade my project to 4.17. When I do so, nearly all my meshes loos their materials and in the level a lot of the meshes aren't visible anymore.... It seems that every actor is listed in the Worldoutliner but they are not visible on screen.

I have tested various ways to convert my scene. I tried to open a copy, migrate a selection of assets one by one and so on. Is there something I forgot to do? I had some similar problems a while ago but didn't manage to solve them either.

Can it be that the folder hirachy is to deep where the project is located?

I hope there is a better way to solve this than adding the materials manually........ :/

Greetings Evil_Fischi

Product Version: UE 4.17
Tags:
more ▼

asked Nov 13 '17 at 05:48 PM in Bug Reports

avatar image

Evil_Fischi
287 8 15 20

avatar image ColdSteel48 Nov 13 '17 at 05:51 PM

try to update to 4.15 first and then go up to 4.17

Also make sure you fix the riderections

avatar image Evil_Fischi Nov 13 '17 at 05:58 PM

Oh ok, I will gie it a try. But why would i need to upgrade it to 4.15 first? Is there a difference?

avatar image ColdSteel48 Nov 13 '17 at 06:02 PM

Just an advice - When I upgraded from 4.14 I upgraded to 4.15 first and it worked fine.

avatar image Evil_Fischi Nov 17 '17 at 09:29 AM

thanks ColdSteel48, it worked. I don't know why this helped, is there maybe someone from the staff that could explain what did not worked?

avatar image ColdSteel48 Nov 17 '17 at 10:19 AM

Hey Evil_Fischi Glad It was helpful...

Well from 4.14 to 4.15 there was a huge delta in shaders - and then a little more in consequent versions...

So I assumed that... 4.15 was the only one that knew how to handle it :P

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question