Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.18 not remembering PIE positions.

I don't believe theres anything I'm doing differently from 4.17 but now Play in New Editor windows' positions are not saved from previous plays.

Product Version: UE 4.18
more ▼

asked Nov 14 '17 at 01:43 AM in Bug Reports

avatar image

16 1 2 5

avatar image Freme Jul 10 '18 at 10:10 PM

So I've got back to the issue (as I saw the answers) and have another solution (tested it on 4k 125% DPI Scale)

Close the Engine. Right click on the UE4Editor.exe > Properties > Compatibility. Check the box for "Override high DPI scaling behavior." Set "Scaling performed by:" to "System".

Works for me. So I don't have to set the Widget Reflector anymore.

avatar image phisigma Jul 14 '18 at 12:55 PM

Best workaround until now, thanks Freme!

But there is still one drop of bitterness: The whole UE editor (including its game windows) is rendered at a lower resolution, corresponding to your DPI factor! For example, I have 4K and 250 % DPI, so representing two PIEs side by side would normally require the PIE resolution to be set to HD (1920x1080). BUT I have to set them to 1920x1080 ÷ 2.5 = 768x432, and of course you can see that there are much fewer pixels.

Nevertheless, still better than my previous workaround :-)

Edit: I once again asked the UE team and finally got the correct ticket number: UE-55372 And once again I ask everyone to vote for this ticket so that this really annoying issue will finally be fixed.

avatar image phisigma Mar 29 '19 at 11:40 AM

You probably won’t believe, but after only four versions of UE this issue is finally fixed with 4.22 :-)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

5 answers: sort voted first

Hello mds3u,

There is an option for this. If you go to Edit > Editor Preferences > Level Editor > Play > Play in New Window, you can uncheck 'Always center window to screen' and it should stop resetting the location of the new window between plays.

Please let us know if you have any further issues.

Thanks, Tyler

more ▼

answered Nov 14 '17 at 02:47 PM

avatar image

Tyler X ♦♦ STAFF
272 2 3 2

avatar image Freme Nov 15 '17 at 05:38 PM


i have this option marked off (see 2.png). Still all windows appear in the middle.alt text

2.png (24.0 kB)
1.png (152.8 kB)
3.png (62.2 kB)
avatar image Tyler X ♦♦ STAFF Nov 15 '17 at 06:39 PM

Hello Freme,

I did notice when testing that these settings did not take the first time I tried, and it was still loading to the middle of the screen. Go back into your settings, make sure the check box is still unchecked, and set the position at 1, 1. Then close the settings again and try it. Let me know if it still does not work.

Thanks, Tyler

avatar image Freme Nov 16 '17 at 10:03 PM

Didn't work. :-/

avatar image mds3u Nov 16 '17 at 10:51 PM

Hey, Tyler. Thanks for your help. So far, even after updating to 4.18.1, UE hasn't remember my position/resolution of adjusted PIE. "Center Window" is indeed uncheck. I tried changing the position to 1,1 and the two PIE windows still appear centered on top of one another.

avatar image Tyler X ♦♦ STAFF Nov 17 '17 at 07:07 PM

Hello mds3u,

Are you running Unreal Engine on Windows, Mac, or Linux? I did find a bug report in for an issue with this on both Mac and Linux.

Thanks, Tyler

avatar image Freme Nov 17 '17 at 07:29 PM

Windows 10 Tried default INIs. Didn't work. Update to 4.18.1 didn't help. Parallel installed 4.17.2 works fine. Any kind of logs that may help?

avatar image mds3u Nov 17 '17 at 09:13 PM

Windows as well.

avatar image mds3u Dec 12 '17 at 08:42 PM

After updating to 4.18.2, problem continues.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users


I have updated the bug report to note that this appears to be happening in Windows as well. Please test this again when the next engine update comes out and let me know if it is still occurring.

Thanks, Tyler

more ▼

answered Nov 22 '17 at 05:25 PM

avatar image

Tyler X ♦♦ STAFF
272 2 3 2

avatar image Freme Nov 22 '17 at 07:13 PM

Deinstalled UE4 and Epic Launcher. Cleaned AppData from UE. Installed everything again. Still occurs...

avatar image Tyler X ♦♦ STAFF Nov 22 '17 at 07:26 PM

Reinstalling the current version will not correct the issue, you will need to install or update to the next engine version when it is released, where this should be fixed. If it still occurs for you at that point, let us know.

avatar image Freme Nov 22 '17 at 07:39 PM

I understand that. Just thought it may help... i don't know.

avatar image phisigma Mar 29 '18 at 10:12 AM

I asked for the ticket number and thus wrote a report. See UE-58037. Vote for it :-)

Edit: It was a duplicate, the real/original/correct ticket is UE-55372 – use this one if you want to vote or get the current status.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4.18. problem still exists.

more ▼

answered Jan 05 '18 at 12:46 PM

avatar image

21 2 7

avatar image mds3u Jan 19 '18 at 11:55 PM

4.18.3. Still happening.

avatar image gregh6ft Jan 31 '18 at 12:39 PM

Agreed. I am now seeing this behavior as well in 4.18.3.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So the issue for me is the DPI Scaling of Windows 10. I'm running a 3840x2160 on 125%. If i set it to 100% the Editor remember the position of the screens.

This is not a fixed and just a workaround.

more ▼

answered Mar 05 '18 at 10:46 PM

avatar image

21 2 7

avatar image phisigma Mar 28 '18 at 11:04 AM

OMG Freme, you’re right! Setting the Window 10 DPI scale to 100 % makes everything working. But with a 4K monitor this is quite inacceptable. Please, Epic, fix this! :-)

avatar image Freme Mar 28 '18 at 11:52 AM

Via (if i remember correctly) Window -> Developer Tools/Content -> Widget (something) you can adjust the UX size for 4k.

avatar image phisigma Mar 28 '18 at 12:18 PM

Widget Reflector.

Yes, looks great, thx Freme. Now the UE editor is really nice, but the rest of Windows 10 is unreadable, as I use 250 %. When I work at my Multiplayer, I am going to set down the Windows resolution to just HD.

avatar image Freme Mar 28 '18 at 12:52 PM

hm.. do you have glasses? or do you sit far away from the monitor? Because 250% is heavy

avatar image phisigma Mar 28 '18 at 04:23 PM

Lol, a yes to both questions!

But no, that’s not very much, it corresponds to 125 % on a HD monitor, or doesn’t it? Windows itself suggests 150 % at my configuration.

avatar image Freme May 07 '18 at 08:38 AM

With the Widget Locator (afaik View -> Dev Tools) you can adjust the DPI directly in UE. You can set it to 1.25 or whatever you like

avatar image TorQueMoD Jul 06 '18 at 09:06 PM

This does nothing for me. My monitor is already set to use 100% scaling as it's only 1080p and the windows are still not where I told them to be and also the first window is filling the screen even though I set the resolution to 960 x 540

avatar image phisigma Jul 09 '18 at 10:49 AM

Strange. Perhaps this only works for 4.18. I assume you did the correct PIE options (PIE instead of Standalone, uncheck “always center …”).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So a better work around is to create a DefaultGameUserSettings.ini file which is located in your UnrealProjects/ProjectName/Config/ folder. I assumed everyone had this ini file but apparently you have to create it manually. For me it came with some graphics settings content I purchased on the marketplace so it's in most of my projects.

The file name has to be DefaultGameUserSettings.ini and you put it in UnrealProject/YOURPROJECTNAME/Config along with the DefaultEditor.ini and all the others.

 ResolutionSizeX=960 ; Disable if you want the engine to set to desktop resolution
 ResolutionSizeY=540 ; Disable if you want the engine to set to desktop resolution
 LastUserConfirmedResolutionSizeX=960 ; Disable if you want the engine to set to desktop resolution
 LastUserConfirmedResolutionSizeY=540 ; Disable if you want the engine to set to desktop resolution
 FullscreenMode=2 ; (Fullscreen=0, Windowed Fullscreen=1, Windowed = 2)

Keep in mind you need to change line 13, 14 and 20 to reflect the screen resolution you want and whether or not you want it to be windowed, full screen or windowed fullscreen

Then when you want to PIE, you need to click on the drop down arrow to the right of the Play button and choose New Editor Window (PIE). This will set the windows correctly. Personally I use this to place two small windows side by side to test multiplayer.

more ▼

answered Jul 06 '18 at 09:19 PM

avatar image

1.2k 86 116 146

avatar image phisigma Jul 09 '18 at 10:46 AM

No, that does not help. There is no file ProjectName/Config/DefaultGameUserSettings.ini, and when I create it with your suggested content, there is no change in behaviour. Using 4.18.

avatar image TorQueMoD Jul 09 '18 at 11:04 AM

Apologies, I didn't include the entire ini file so maybe that's why it's not working. I've updated my answer to reflect the changes.

avatar image phisigma Jul 10 '18 at 11:35 AM

Sorry, but your suggestion really does not work. Perhaps it works for you by coincidence just because your DPI scale is 100 %, or you use 4.19 or 4.20 …

avatar image TorQueMoD Jul 10 '18 at 07:13 PM

Strange. No, I'm using 4.18. The ini files are what determine these sorts of things so it's certainly not coincidence. Maybe it's because I'm running a 1080P monitor and not a 4k then but I had the same problem originally with my 1080P monitor and editing the DefaultGameUserSettings.ini fixed it for me. Sorry I couldn't solve your problem. Good luck!

avatar image TorQueMoD Jul 10 '18 at 07:18 PM

Oh hey. Try checking your DefaultEditorPerProjectUserSettings.ini - This is where all of the settings for the PIE get saved. Specifically these settings:


And these:


avatar image Freme Jul 10 '18 at 09:42 PM

Maybe there are different issues. I can easily reproduce the error when I'm using Windows DPI Scaling. But PIE Positions are all set correctly.

avatar image TorQueMoD Jul 10 '18 at 10:06 PM

hmmm that's weird. Ok well I'm out of ideas then. Sorry guys.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question