x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal rendered output not matching maya output

Hello, I am using Unreal to create a 4000 frame pre-rendered animation. Everything was created in Maya and exported into Unreal. Since unreal doesn't yet (to my knowledge) have support for animated textures, I am using Maya to render out some parts that require animated textures. However, when I composite the unreal and Maya rendered frames together (created with what should be the sane camera) they don't quite lineup 100%. . There seems to be some wobbling in the rendered output from Unreal. Also the output from unreal seems to be more steppy and less smooth then the original animation in Maya.

The camera animation was created in Maya. the animation was baked to a cube, that cube parented under a root cube, and that animation imported as fbx into unreal. Using the Skeletal Mesh import option with Import Rigid Mesh checked, imports the 4000 frame animation as 3866 frames.(not sure why?) However using the Animation import and use default sample rate brings in the correct 4000 frames . I have also made sure the lenses are the same on the cameras . Anyways, everything should all be lined up but somehow the rendered output from Unreal is slightly off, and looks more steppy and less smooth then the maya animation. Any ideas why this would be the case? Should Unreal be outputting 100% accurate frames, or is the fact that it is designed for real time games somehow making it less accurate for this purpose??? Also, is the fbx import somehow changing the animation curves?

Any help or ideas on this would be greatly appreciated! Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Jul 21 '14 at 05:18 PM in Rendering

avatar image

Spectral Illusions
86 11 12 16

avatar image Spectral Illusions Jul 21 '14 at 10:46 PM

Ok I have been going over everything I can think of on this. playblasting a wireframe of the scene out of maya and comping it over the rendered frames from unreal, everything is mostly lining up, yet there is an instability about the rendered frames from unreal. Like the render isn't putting everything 100% exactly where the wireframe says it should be. Is the renderer somehow sacrificing accuracy for speed? Why why why is this behaving this way? I can upload a video if of the problem if that would help. Thanks!

avatar image Lovecraft_K ♦♦ STAFF Jul 22 '14 at 03:44 PM

Hey Spectral Illusions -

A video would be most helpful so we can see exactly the problem points. If you are willing to share the FBX that also would be helpful so we can physical look at the process of importing that asset and test it for you.

In the meantime, I am beginning to see if I can reproduce this issue from your description.

Thank You

Eric Ketchum

avatar image Spectral Illusions Jul 22 '14 at 05:34 PM

Hi Eric, Can I send you an invite to a dropbox folder with the video of the problem? What email should I send invite too? You can reply to me directly at rostirfx@gmail.com. Thanks! I am now thinking its not a camera issue but rather some sort of texture stability issue, but you will be able to see in the video.

avatar image Lovecraft_K ♦♦ STAFF Jul 22 '14 at 06:40 PM

Hey Spectral Illusions -

Ok, can you let me know what if any your post process settings are? Try disabling Motion Blur by checking the box and setting the value to 0. This is my first guess, but let me know all the settings as well.

Thank You

Eric Ketchum

avatar image Spectral Illusions Jul 22 '14 at 06:53 PM

Yes Motion Blur was one of my first ideas, but even with it turned off as you say the wobble was still there. I turned it back on in the render I sent since it didn't seem to effect the wobble. The test you have has the following post process settings Film Tint shadow checked with a color Tine Shadow Blend 0.1 Tint Shadow Amount 1.0 Saturation .637168 Tint colored Bloom Intensity 2.0 Motion Blur amount 0.5 Those are the ones I have checked and have changed. Everything else should be the default GlobalPostProcessVolume that loads with the starter scene. Let me know if there are other setting info you need. Thanks

avatar image Spectral Illusions Jul 22 '14 at 07:00 PM

Also some of the most problematic areas are right down the center of frame where I would expect little motion blur to occur. The geometry for most of these walls are just cubes with the textures on them. Maybe the geometry needs more faces?

avatar image Lovecraft_K ♦♦ STAFF Jul 22 '14 at 07:32 PM

What type of camera did you us in Maya to set up the animation a standard camera or a view target camera?

avatar image Spectral Illusions Jul 22 '14 at 07:50 PM

In maya It is a standard camera that is parented under a cube that is motion path attached to a curve. All the animation comes from the cube.(cam i That cube is baked out, parented under another cube and exported as fbx.I also have a frame 0 where the animation is all at 0. In Unreal I import it as a skeletal mesh with import animation and import rigid mesh and import meshes in bone heirarchy all checked. I put the imported cube in the scene with all T's and R's at 0. Then I attach the animation, making sure that Always Tick Pose and Refresh Bones is on. Then I parent a new unreal camera to the animated part of the cube, and make sure T's are all 0 and R's are x -90 y -90 z0. Next using blueprint I make this script http://blog.environmentartist.com/?p=1166 making sure the new camera is the one being called. Now when I hit play the camera animation plays.

Back in Maya I am using the same baked cube to drive the camera there so they should be the same.

avatar image Lovecraft_K ♦♦ STAFF Jul 22 '14 at 08:07 PM

Does your Skeletal Mesh when imported generate a Physics asset? If so, you might need to open the Physics Asset and disable any linear or radial movement in the physics asset. This could cause the twitching of the scene that we are seeing.

Let me know -

Eric Ketchum

avatar image Spectral Illusions Jul 22 '14 at 08:15 PM

No it doesn't look like it is generating a Physics asset. When I look at the Physics Asset it says None and when I browse I see no Physics assets for any of the cameras I have created this way.

avatar image Spectral Illusions Jul 22 '14 at 08:56 PM

Hi Eric, I have uploaded the fbx files to dropbox. There are 3 files, the camera animation cube, and exterior and interior geometry. Thanks

avatar image Spectral Illusions Jul 22 '14 at 09:33 PM

Ok this has just gotten even weirder. The animation is a 4000 frame loop. I have also included a frame 0, and another 4000 frame loop after the initial (so 8001 frames total). When I render out all the frames and try to match the frames from the first loop around to the second, the frames are slightly different. I would expect they should be identical since the animation should be the same, but it's almost like unreal is creating the frames from the curve but not always hitting the exact keys for each frame (even though every frame has a baked key). Like maybe values that are somewhere along the curve but not the exact key values at the exact frames???

avatar image Spectral Illusions Jul 22 '14 at 09:43 PM

actually the 2nd loop part may be a frame off, I'm going to redo and test now.

avatar image Spectral Illusions Jul 23 '14 at 01:08 AM

Just retested and still same results. I have the animation for the loop going through twice. The animation should be exactly the same for both loops, yet unreal is simply not outputting the same frames. Again, the wobble remains. There should be 2 frames in the sequence that are identical for each frame, yet they are not. Somehow Unreal is not interpreting the animation correctly or consistently.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok somehow I have fixed the issue! Although the frames rendered from the first part of the loop still have the wobble, and the frames rendered from the 2nd part of the loop don't match up with the first part, they are actually correct! It really makes no sense at all, but it's working now and completely locked! Thanks for all your help! It's still a mystery why the first time through the animation would be off but the second part locked when they should be the exact keys, but it's working now. In future updates it It would be great to have the ability to import Maya cameras directly into unreal, with animated focal length. Also support for animated textures! Thanks!

more ▼

answered Jul 23 '14 at 06:14 AM

avatar image

Spectral Illusions
86 11 12 16

avatar image Lovecraft_K ♦♦ STAFF Jul 23 '14 at 03:31 PM

Congrats, I'm glad you got it working. We are working on improving the CameraAnim element which will allow for importing camera animations from Max and Maya.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question