x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint Add Component Function Needs to be Deleted and Re-Added anytime a change is made.

I am using the add component function for a custom scene component. The custom component is written in C++ and is extended in Blueprints. I can add the custom component using the "Add Interactive Widget" node as shown (which is fine).

alt text

In the implementing blueprint, I have to delete and re-add the Add Interactive Widget node anytime anything is change in the Interactive Widget component. And I mean ANYTHING. When the node loses its mind, it turns into a generic node as shown: alt text

To fix I have to delete and re-add:

alt text

And we are all good. If I change anything in the component (in this case I just added a custom event and that was it) and save/compile it:

alt text

You can see that the Node has already lost it's connection to the interactive widget component by becoming a generic "Add Component" node before I even attempt to compile the implementing blueprint. This is when I have to delete / re-add to fix:

alt text

Product Version: UE 4.18
Tags:
error.png (174.4 kB)
fixed.png (134.0 kB)
added.png (171.7 kB)
brokeagain.png (134.0 kB)
add.png (120.8 kB)
more ▼

asked Nov 14 '17 at 02:53 PM in Bug Reports

avatar image

falconblade
6 1 3

avatar image Xelj Nov 14 '17 at 10:41 PM

I always thought that addcomponent node can not be used alt text

1.png (61.1 kB)
avatar image Trey Z ♦♦ STAFF Nov 15 '17 at 07:45 PM

Hey,

How did you call the Add Component node in your first screenshot? I can't find any component node that is general like that. All are specific components like Scene or Static Mesh. Listing some detailed repro steps would help out.

avatar image falconblade Nov 15 '17 at 07:53 PM

I actually didn't. I did exactly what you are saying by "Add Interactive Widget", which was specific. It isn't until I make a change in the "Interactive Widget" component that it becomes a generic node like that with the error showing on the bottom. So, yes... sorry about that... the first step is adding a component specific node. I have edited the above to hopefully help with some confusion.

avatar image Trey Z ♦♦ STAFF Nov 15 '17 at 08:21 PM

I can't find "Add Interactive Widget" anywhere in the editor even with 'Context Sensitive' off. When you are saying you " have to delete and re-add the Add Interactive Widget node anytime anything is change in the Interactive Widget component", is this in regards to the blueprint or component class? Also if you don't mind can you also attach a copy of your project for me to look at?

avatar image falconblade Nov 15 '17 at 09:31 PM

I can recreate this by creating a blank project and adding two blueprints, one the inherits from a scene component and one that inherits from an actor.

alt text

In the MyActor blueprint I add the "Add My Scene Component" node to begin play:

alt text

And then change something in "My Scene Component":

alt text

And the actor Node has changed to a generic node and is no longer connected to the MySceneComponent node:

alt text

twoblurpints.png (38.2 kB)
step2.png (37.2 kB)
step3.png (69.2 kB)
step4.png (43.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey,

I was able to replicate the issue. I have logged a JIRA ticket with the developers for them to address this. You can access UE-52484 at anytime to check the status of the bug.

more ▼

answered Nov 16 '17 at 08:21 PM

avatar image

Trey Z ♦♦ STAFF
997 3 4 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question