x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

(RESOLVED) Camera through object

When I move camera, it goes through objects. What have I to do to avoid this problem? In all games the camera block when bumping walls and so on.

Product Version: UE 4.18
Tags:
more ▼

asked Nov 16 '17 at 04:34 PM in Using UE4

avatar image

Young Pope
9 3 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Attach the camera to a Springarm component; then, in the Springarm settings, you can control the size of the probe and other things:

alt text

Enabling camera lag will give you nice, automatic smooth interpolation, too. Give it a try.

capture.png (22.6 kB)
more ▼

answered Nov 16 '17 at 05:12 PM

avatar image

Everynone
14.6k 76 25 61

avatar image Young Pope Nov 16 '17 at 05:24 PM

No, it doesn't work

avatar image Everynone Nov 16 '17 at 07:40 PM

It does work. It's even in the 3rd person template that comes with the engine...

Show us how you set it up.

avatar image Young Pope Nov 16 '17 at 08:49 PM

alt text alt text alt text alt text

cattura.png (403.6 kB)
cattura1.png (1.4 MB)
cattura2.png (48.8 kB)
cattura3.png (36.2 kB)
avatar image Everynone Nov 16 '17 at 09:08 PM

You already have a springarm - CameraBoom is just a renamed spring arm - make sure collision is enabled there. You do not need the second one.

Does your level geometry have collision?

avatar image Young Pope Nov 16 '17 at 09:34 PM

I've tried but nothing. Can you send me your setting just you say it works for you?

avatar image Everynone Nov 16 '17 at 10:02 PM

There are no settings, that's the default behaviour. Just run the 3rd person example that came with the engine. You have a perfect example right there.

https://gyazo.com/749deba2487bc31239462f3c6b6fa1a7

avatar image Young Pope Nov 16 '17 at 10:06 PM

So... I think it depends by the objects in the world. In the exemple level there are preset objects, maybe they are setted in order to avoid this problem, What do you think?

avatar image Everynone Nov 16 '17 at 10:47 PM

You will need collision for that. What are your walls' collision settings?

The probe on the springarm uses a Camera channel to test collision so you need to ensure that the level geometry has is enabled as well (among other channels that handle collision, that is):

alt text

You'd need to ensure that your meshes have collision in the first place, too.

capture.png (19.9 kB)
avatar image Young Pope Nov 16 '17 at 11:07 PM

I've resolved. I changed the position of the camera and so it disconnected by the spring arm. I've reset its location and now it works. Thank for time spent for me!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question