x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

My characters do not move once I set their location.

I have 3 pawns that have to solve puzzles, then their locations are set to certain points at another spot in the world. But 2 of them, when moved to those locations, do not move. They only run in place. The first one does move freely though. I use the same nodes to move all three. I am doing nothing to stop their movement, that I know of, so I'm not sure what's wrong. Any help is appreciated.

Product Version: UE 4.16
Tags:
more ▼

asked Nov 16 '17 at 05:26 PM in Blueprint Scripting

avatar image

Truth in Thorns
6 1 1

avatar image JonathanLambert Nov 16 '17 at 05:56 PM

What does your nav mesh look like?

avatar image Truth in Thorns Nov 16 '17 at 05:58 PM

I'm not very familiar with everything, sorry. Would that be on my character or something in the map?

avatar image JonathanLambert Nov 16 '17 at 06:27 PM

hit "P" and you should see a green mesh. That mesh is how your characters know where they can or can't move to.

avatar image Truth in Thorns Nov 16 '17 at 06:30 PM

alt text

This is what it shows.

scrnht.png (1.1 MB)
avatar image Truth in Thorns Nov 16 '17 at 06:32 PM

The closed off room is where their locations get set to.

avatar image JonathanLambert Nov 16 '17 at 06:51 PM

Take another screen shot with the pawns at that location. Check to make sure that none of the character's components can affect navigation.

avatar image Truth in Thorns Nov 16 '17 at 07:17 PM

alt text

This is them after their locations got set. The components I have on all of them are just the default ones: capsule component, arrow component, skeletal mesh component, spring arm component, camera component.

scrnht.png (1.2 MB)
avatar image Truth in Thorns Nov 16 '17 at 08:36 PM

The problem was that the conditions to set two of the characters' locations(the two that wouldn't work) was being checked in Event Tick. I didn't realize that it was continuously setting their locations every time Tick was being called. I put a do once node after the conditions were true, so now it works. Thank you for your help, though.

avatar image JonathanLambert Nov 16 '17 at 08:36 PM

Are they all the same class? You can see the nav mesh while PIE by pressing the tilde key and typing the command "Show Navigation". That way you can see if the nav mesh is getting broken at run time.

avatar image Truth in Thorns Nov 16 '17 at 08:37 PM

Check my comment above lol. We commented at the same time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question