x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cascade modules extremely small on 4k screen in 4.18

The cascade modules are extremely small on 4k screens in 4.18.1.

Video showing difference between 4.16 and 4.18.1 (also works fine in 4.17)

https://www.youtube.com/watch?v=elMzyuDcuVA

Product Version: UE 4.18
Tags:
more ▼

asked Nov 16 '17 at 10:53 PM in Bug Reports

avatar image

Luos
9.1k 282 62 327

avatar image Skifree Nov 21 '17 at 04:34 AM

I too have this. It's frustrating. Using a macbook retina 15"

avatar image greemVFX Dec 15 '17 at 05:48 AM

hello, i'm studying unreal vfx. i have a same problem.

can i know how to this? " for Windows users, I would suggest launching the editor with -nohighdpi to display High DPI which is likely causing this issue. "

my display pixel is 2880 * 1800.

avatar image Matthew J ♦♦ STAFF Dec 15 '17 at 04:00 PM

Hello greem0308, you can add this command by either running your .uproject file for your project from the commandline and adding -nohighdpi to the end of the command or you can make a shortcut to accomplish this. When making a shortcut, make a shortcut to the .uproject file for your project and then right-click the shortcut and open its properties. In the Target field, add -nohighdpi to the end of the entry, after the quotation marks.

avatar image Luos May 09 '18 at 01:09 PM

Hello Matthew,

This is not fixed in 4.19 as a matter of fact, its worse. https://i.gyazo.com/8e41b67e198156553497b476e5bdf0a0.gif https://i.gyazo.com/9ab760ddf6efcef7eb2830df3c4431c7.gif

it now randomly switches between dpi scales, cant move modules, and well.. I cant work like this so now I have angry clients.

avatar image Matthew J ♦♦ STAFF May 09 '18 at 05:00 PM

Hello Luos, I'll attempt to reproduce this shortly. In the meantime, are you sure that this was broken in 4.19.0 and not broken in 4.19.1, or 4.19.2? I assume that you have been on 4.18 until this point?

While it isn't a suitable fix, you should be able to continue work by working around this by using a 1080p resolution if you need an immediate solution.

Have you tried enabling/disabling the High DPI settings in Editor Preferences? They are "Enable High DPI Support" and "Disable DPI Based Editor Viewport Scaling". These settings have unexpected results at times. Issues such as this are also usually linked to the scaling options in Windows, so I would suggest attempting to disable that (by setting it to 100% scaling) as well.

avatar image Matthew J ♦♦ STAFF May 09 '18 at 05:19 PM

We were able to reproduce the issue in your first gif, with the problem with the Drag and Drop of the modules in Cascade being off. We do not see the issue related to the different scaling for different tabs however. Was there anything additional you did that made this occur?

We also noticed that disabling the "Enable High DPI Support", while not an ideal fix, does fix the issue with the Drag and Drop. We'll get a bug in for the Drag and Drop feature in the meantime.

avatar image Luos May 09 '18 at 05:29 PM

Hey Matthew,

latest 4.19 version, havent tried 4.19.0 / 4.19.1 I have one 1080p monitor and the problem is still there.

Need to try "enable high dpi support" and "disable dpi based editor" still. Scaling my 4k monitors (and 2k monitor) back to 100% makes everything unreadable so that is not a viable option.

Changing dpi settings in the 4.19.2 editor.exe doesnt result in any changes btw.

The scaling stuff is probably reproducible when you drag one cascade window to another 4k monitor, open a 2nd emitter, drag its cascade window to your first 4k monitor and let go of it. then drag either cascade window onto the other so they are one tab. the window you dragged the other window towards will now have a different dpi until you drag it out of the tab onto another 4k monitor and let it go. repeat to create same issue over and over again.

I need to do a bleepload of chores now, but I'll try to record the issue which might be a bit hard because I'll need to record (at least) two screens at once.

avatar image Luos May 09 '18 at 07:29 PM

https://www.youtube.com/watch?v=ewXVhPgwFyU

I was right, I can recreate the dpi random bug thingy every time. might want to wait half an hour or so because I recorded this at 4k, so I could capture both monitors at once. though.. I dont think you dont even need two monitors and can do it on one.

avatar image Luos May 09 '18 at 07:29 PM

(also, this is annoying af)

alt text

avatar image DotCam May 11 '18 at 07:14 PM

@Luos If you right click your desktop and go to Display Settings, do you use any scaling beyond (or below) 100%, or do you use a DPI higher than 72?

I have to sit back a bit from my 4k monitor so scaling is at 125%, but haven't run into that jumpy textbox issue (but I have experienced it in the past on 1080p a couple years ago).

p.s. Where did you find that dark theme? If it's a custom CSS stylesheet you should try removing it temporarily to see if the textbox styling override is causing the problem.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hello Luos and Skifree,

From testing in our latest internal build, the issue seems to already be resolved, as we were able to reproduce this in 4.18 but not on our latest. This means that I will not be placing a bug report in for the issue. The fix should be present in 4.19's release.

In the meantime, for Windows users, I would suggest launching the editor with -nohighdpi to disable High DPI which is likely causing this issue. For Mac users, the equivalent would be to disable HighResolutionCapable within Info.plist (Engine/Binaries/Mac/UE4Editor.app/Contents).

more ▼

answered Dec 12 '17 at 09:23 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 91 417

(comments are locked)
10|2000 characters needed characters left

Thank you for that video, Luos. We've reproduced that issue as well and, since these issues are likely related, we entered a bug report that encompasses both of them. You can find the bug report here:

https://issues.unrealengine.com/issue/UE-59028

For future bug submissions (this is an exception since this ticket already had existing info), please be sure to send us a submission over at our Bug Submission Form

We will mention the issue with the text boxes on Answerhub but it's not something that we would track in our JIRA, as we do not make the direct changes to Answerhub.

Thanks again and have a nice day.

more ▼

answered May 11 '18 at 04:48 PM

avatar image

Matthew J ♦♦ STAFF
31.8k 526 91 417

avatar image Luos May 11 '18 at 09:58 PM

Hello Matthew (and crew) I really appreciate you getting back to me and giving me an update on whats happening.

While I know cascade will be phasing out over the next few builds, its appreciated to have it working properly for at least a good period of time due to projects quite far in production. So its good to see bugfixes like these will be made and bugs like these are taken serious!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question