x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Importing complex rig from Maya to UE4 4.17 - skeleton not imported properly

Hello all the good people of this community!

For few days by now I have an big problem exporting complex rig to Unreal Engine.

I just want to state few initial things:

  1. I know that the fancy/complex animations have to be backed into FBX in order to work in UnrealEngine.

  2. I am after few different tutorials of exporting Maya -> FBX and importing FBX -> UE4, with no luck.

Overall, I know the idea behind exporting/importing from Maya to Unreal Engine, but the problem lays somewhere in details / options / steps. When you decide to post an answer, please consider I am not very experienced so elaborate whenever you can ;)

What I want to do?

So, my aim is to import Mery rig which is free for non-commercial study projects: https://www.meryproject.com/download

You can download it from there for free to follow the steps I make and to reproduce everything I describe.

With What?

I use Maya 2017, Unreal Engine version 4.17.2, no external plug-ins.

Why not ARTV1?

It's not working with Unreal Engine version 4.17.2, and ARTV2 alpha which does, does not support what I need - facial animations etc. And I want to export already created Mery rig instead of rigging character from start.

First, naive try

I know I made few mistakes it the first try, but showing it step by step will help you to tell me where I do the wrong move.

What I did: Select all and export to FBX, then import into Unreal Engine.

What I got: alt text

What was wrong: Character has been spited into several different pieces.

Solution: Merge the fragments of the mesh.

Second try - merged mesh

I did so by selecting geometry that are actively used (Mery rig has additional clothes etc. that can be switched with eye icon on the rig, but I did not select them) and pressing "combine": alt text

So I got: alt text

Ok. Single mesh.

Now the export:

I select with CTRL both the single mesh I have now and the Mery_grp_rig. I go to File -> Export Selection.

I choose FBX with parameters:

  • type: Binary

  • version: FBX 2014/2015

  • Geometry: only Smooth Mesh and Referenced Assets Content checked

  • Animation: checked

  • Bake Animation: checked

  • Resample All: checked

  • Constraints: both Constraints and Skeleton Definitions unchecked

  • Deformed Models: checked alt text

I hit the export. I know I don't yet have any animation in my Maya but it doesn't matter. I have problem with importing rig for now.

I get several warnings and errors (most of them seem to be "ok" as e.g. I'm ok with complex animation being baked or):

alt text

Now I go to Unreal Engine 4 and in prepared folder I hit Import next to Add New in Content Browser.

I select those options:

alt text

And hit "Import All".

After import is finished I get: Click and drag to move

So as you see, there are materials and mesh (don't mind shoes - I didn't combined those sub-meshes) imported. The problem is, the skeleton shows just Mery_geo_cn_body which is the name of mesh and not a skeleton - I don't have any hierarchy here.

Another try - messing with export parameters

Upon exporting FBX from Maya I've this time selected Constraints -> Skeleton Definitions:

  • type: Binary

  • version: FBX 2014/2015

  • Geometry: only Smooth Mesh and Referenced Assets Content checked

  • Animation: checked

  • Bake Animation: checked

  • Resample All: checked

  • Constraints: Constraints unchecked and Skeleton Definitions checked

  • Deformed Models: checked

I get some warnings again: alt text

And after importing the mesh I got exact same result with no skeleton whatsoever: alt text

I was further experimenting with warnings, export options and so on, got some strange results sometimes but so far I've not managed to get the mesh and rig to get exported. Not to mention the animations for now.

Do you see what I do wrong here? What can I try?

Thanks in advance! And note me if I didn't provide some information needed.

Product Version: UE 4.17
Tags:
t1.png (235.1 kB)
t2.png (261.4 kB)
t3.png (195.9 kB)
t5.jpg (279.3 kB)
t4.png (74.6 kB)
more ▼

asked Nov 16 '17 at 11:45 PM in Using UE4

avatar image

FeyDreamers
15 1 5 6

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

In case of you importing your .fbx file, you just need import your root geometry/model (based on hierarchy) and root of your rig (based on hierarchy) before you export your .fbx file. So you just need to select 2 object in outliner before you export it.

Unreal can't read curve and any object, I tried this few days ago. I also tried to manipulated controller by usin geo and joint. But the problem is maya constraint couldn't be read by UE4. I think it because scripting language (e.g. MEL to C++ or MEL to Python to C++ etc.)

So from now on you and I might be see that the difference between rig in maya and rig in UE.

So I suggest you basic simple pipeline. Model with skeleton and baked animation.

One: Select your root binded geometry and root joint inside maya, make it sure there's no key animation, then export it as *.fbx file. be sure using prefix (e.g. char_marryRig.fbx)

Two: Open your animation file in maya, select your root joint only and then expor it as *.fbx also using clear previx (e.g. anim_marryRig_iddle.fbx)

Those 2 files will related as long their joint name still same.


Here some link that might help you out:

https://docs.unrealengine.com/en-us/Videos/PLZlv_N0_O1gb2ZoKzTApbv3LvhaXJ9elg/KHGyVJ4LD6Q

https://www.youtube.com/watch?v=JkcJ5bjGPsg&t=209s


Another solution is you can use allrightrig.

There's free beta version and fully function by purchasin it

http://alexallright.com/allrightrig/

more ▼

answered Apr 17 '18 at 04:17 AM

avatar image

prana ronita
21

(comments are locked)
10|2000 characters needed characters left

Hey man, I have a tank model with 100+ unique parts all neatly organized and combined into parent groups and they ALL import seperately, leaving me with 300+ parts including duplicates (track pieces).

I have no idea why this is happening. I did not have this issue in 4.12....

Any infos on that? What am I doing wrong?

more ▼

answered Feb 05 '18 at 07:16 PM

avatar image

Hannsie
1

(comments are locked)
10|2000 characters needed characters left

If you're using Maya - you can make sure the mesh doesn't import as skeletal objects if it's under a Maya LOD group.

Select all the mesh objects, and go to Edit > LOD (Level of Detail) > Create LOD Group. And then export with that group.

alt text

fix.png (7.1 kB)
more ▼

answered Mar 15 '18 at 11:10 PM

avatar image

SD_Gzer
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question