x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Connect to dedicated server remotely

I followed this guide here: https://wiki.unrealengine.com/Dedicated_Server_Guide_(Windows_%26_Linux) for windows and it worked perfectly. I am now trying to go from opening a level with my localhost, to opening a level with my public IP and I am having some issues.

I replaced Level Name with my gateway's public IP. I recompiled and saved the level, and repackaged the project. I then went to my router's settings and set up my desktop with a static IP (10.0.0.253), and set up port forwarding for port 7777 (I'm pretty sure I have done this part right, as I have a PLEX server that works remotely). I then went to my firewall, and ensured that all incoming/outgoing traffic onto port 7777 would be accepted.

After launching my server.exe as I did before I get the following output: https://pastebin.com/em0SzkRg which seems fine to me. But when I open my game.exe I get a blank screen, and no new output on the server log. So I tried to see if the port was open using yougetsignal.com, and testing port 7777 I get that it is closed. I check if my PLEX port is open on this site, and it is open, and my PLEX is setup the same way unreal is.

I then check netstat -AN from the command line and I notice that PLEX has the following entry: TCP 10.0.0.253:32400 10.0.0.253:61938 ESTABLISHED and my 7777 has the following entry: UDP 0.0.0.0:7777 *:*

I am truly at a loss right now, I feel like the issue has to be with the unreal server exe as my PLEX connection seems to be fine, but I have followed every part of the dedicated server guide.

thanks for any help

Product Version: UE 4.17
Tags:
more ▼

asked Nov 17 '17 at 05:36 PM in Packaging & Deployment

avatar image

tckelly38
1 2 3 4

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question