x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Metal textures from CoreVideo render black when SteamVR is enabled on Mac

I am attempting to render Metal textures obtained from the camera on macOS. To do this, I am using a core video capture session, and the resulting metal texture in a similar fashion to how the 4.18 ARKit plugin code works (i.e. avoiding CPU <-> GPU round trips).

This works as expected when VR mode is not enabled (i.e. SteamVR not running, and no headset connected when starting the editor).

However, when SteamVR is running (and an HMD connected) and the editor is started with 'VR mode' enabled, the rendered texture appears black, and occasionally flashes solid red/green/or blue.

Presumably this is either a macOS metal issue, a graphics driver issue, or a UE4 rendering issue. I am running macOS 10.12.6 and UE 4.18 on a MBP with nvidia 750M GPU (with Apple nvidia driver).

Any ideas as to the cause? Thanks in advance.

Product Version: UE 4.18
Tags:
more ▼

asked Nov 19 '17 at 03:20 PM in Rendering

avatar image

drh
6 1 3

avatar image drh Nov 20 '17 at 09:57 AM

In addition, switching between forward and deferred render path doesn't make a difference.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Going to answer my own question - updating to macOS High Sierra fixed the issue.

more ▼

answered Nov 21 '17 at 10:02 AM

avatar image

drh
6 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question