x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Video textures working on iOS with ARKit

Hi, I have had no luck getting video textures to work on iOS- only a black texture. I've tried many different resolutions and data rates, as well as many codecs in Quicktime (Prores, H.264, Hap) and mp4 (H.264 & H,265). Ideally I would like to be able to play a 360 video with ARKit, but for debugging purposes am willing just to get any video file to work. I've had no problems doing the same building for Android and Windows. Should I be treating video differently for iOS? Is there a sample video that has been used to test video playback on iOS that I can test with? Thank you!

Product Version: UE 4.18
Tags:
more ▼

asked Nov 20 '17 at 11:01 PM in Bug Reports

avatar image

todernst
16 4 6 8

avatar image Rudy Q ♦♦ STAFF Nov 21 '17 at 03:17 PM

Hello todernst,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean (non AR) project?

  2. Could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any settings/blueprints that may be involved with this issue?

  4. When testing are you launching on or packaging out the project?

  5. Could you make sure that your video(s) have been placed inside of a movies folder within your content folder?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Rudy, The issue was only with the launcher. Video worked for ios (both AR and non AR) when built as a *.ipa and installed on the ios device. Thank you, -Todd

more ▼

answered Nov 27 '17 at 01:09 AM

avatar image

todernst
16 4 6 8

avatar image PfazFWC Dec 15 '17 at 12:17 PM

I had this issue as well, the launcher does seem to be the issue, *.ipa worked fine

avatar image IslandPlaya Apr 09 '18 at 01:02 PM

This issue still exists in 4.19. Thanks for the heads up on the solution.

avatar image 一日同风起 Nov 15 '18 at 07:22 AM

still exists in 4.20, only .ipa work

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question