x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine crashes when creating a media texture asset

Hello,

I have a problem in the version 4.18.1. of the engine with the media texture assets because the engine crashes while creating this asset needed to work with media players and videos in my application. I have tried to create the media texture asset, or to create it through the media player asset checkbox. The editor crashes, does any one know how could I work with this asset or if this bug will be fixed in the following patches?

Thanks in advance.

Mike

Product Version: UE 4.18
Tags:
more ▼

asked Nov 21 '17 at 04:13 PM in Bug Reports

avatar image

ggmike1991
21 1 2 6

avatar image gmpreussner STAFF Nov 21 '17 at 04:22 PM

Please include callstack and log files, otherwise we can't help, thanks!

avatar image hntrhntr Nov 22 '17 at 04:58 PM

I'm having the same issue. The call stack and log is attached.

diagnostics.txt (97.5 kB)
myproject2.log (39.9 kB)
avatar image gmpreussner STAFF Nov 22 '17 at 05:24 PM

Thanks for the logs. Looks like this is macOS specific. We will try to repro it,

avatar image Coates Trevor Feb 10 '18 at 09:26 PM

Still not totally fixed in 4.18.3. I had a Media Player system set up in UE4.18.3 the was working all the way to running it under ARKit on an iPad. Worked for a number of weeks.

Made a change to swapping the materials out between a 2D texture material and the Video Material. This was a feature that I had working from the start but decided to take it out. This was when the crashing started.

I rebuilt it the way it was originally and it still crashes. When I disable the problematic Blueprint and add a test plane set up to run video it runs including the disabled video plane because it still carries the video material correctly set up and is visible in the scene.

What is strange is that it was all working then just by making a change that simplified the set-up it starts crashing.

avatar image Coates Trevor Feb 10 '18 at 09:36 PM

This is part of what is quoted in the Crash Reporter: #0 at 0x7fff6333ee3e *** Terminating app due to uncaught exception 'NSRangeException', reason: 'Cannot remove an observer for the key path "status" from because it is not registered as an observer.'

It has been claimed to be fixed in hot fix 18.3 however I am running 18.3.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello ggmike1991,

After taking a look at the information provided I was able to find that this appears to be a known issue. I have provided a link to the public tracker please feel free to use the link provided for future updates.

Link: https://issues.unrealengine.com/issue/UE-51940

Make it a great day

more ▼

answered Dec 05 '17 at 12:43 AM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question