x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to run dedicated server on packaged project

Hello, i'm using the pre-compiled version of the engine and i've packaged my project to windows. He generated a WindowsNoEditor folder in which he has the exe in the Binaries\Win32. I looked up online and found this page, which states:

To launch a dedicated server, use the command line: < mygame.exe > -server

So i go to the console and write MyProject.exe Example_Map -server, but he starts the game normally, i've also tried MyProject.exe Example_Map?listen -game but the behaviour is the same, which is a game with only the authority and not a client part so most of my client exclusive code does not run. Do you know what i'm doing wrong? Thanks

Product Version: Not Selected
Tags:
more ▼

asked Jul 22 '14 at 12:04 AM in Packaging & Deployment

avatar image

xlar8or
5.9k 152 126 300

avatar image skeleton60 Sep 30 '14 at 01:45 PM

same here i cant run my game as dedicated server doing the same step as you

mygame.exe map -server or mygame.exe map?listen do the same thing

if someone found how to launch a dedicated server i would like to know how :)

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

From my tests i came to the conclusion that the Shipping version doesn't have the console and the .exe init arguments. I compiled a Development build and it worked fine.

more ▼

answered Sep 30 '14 at 11:55 PM

avatar image

xlar8or
5.9k 152 126 300

avatar image mightyenigma Jan 23 '19 at 01:07 AM

Didnt work for me. dev build launches normally and brings up a rendering game window with sound and everything instead of acting like a dedicated server

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question