Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4Editor.exe - No disk

Hi ! =)

I'm getting an error everytime I'm launching the game engine that tells me approximately that:

There is no disk inside the disk player. Please insert a disk in the disk player \Device\Harddisk4\DR4.

(I'm french so I'm not really 100% sure of the translation but I think that the meaning is the same)

For your information: the game engine doesn't crash after this error, doesn't matter if I click on "Cancel", "Restart" or "Continue". So, is it an already known bug ? Does this apply only to the "other than English languages" because of a translation/path-name error ? Or is it something else that can be patched later on ?

Here is a screenshot to illustrate my point:

alt text

Thanks in advance for your reply,

Best regards,


Product Version: Not Selected
more ▼

asked Jul 22 '14 at 12:00 AM in Bug Reports

avatar image

46 3 4 24

avatar image Jacky Jul 22 '14 at 12:11 AM

This doesn't look like an UE4 or Launcher specific issue, it's just another weirdness of Windows. To start off;

  • Do you have any external storage device plugged into your computer?

  • If so, are you downloading those projects to an external HDD?

  • Is any of your HDD's(or SSD) full by any chance?

avatar image WBS_PRO Jul 22 '14 at 12:53 AM

Hi ! Thanks for your reply,

I currently have:

  • a 128Go SSD that contains mainly my Windows 7 OS

  • two 2To HDDs in RAID 1 (Mirror) for all of my data

  • I've also got 3 USB keys for various usages plugged into my computer

At this point my SSD space is approximately 17Go free and my data HDDs are 20Go free (I'm currently downloading various projects of the marketplace if it has any relevance for the problem, there is only one left and it is 4.1Go).

I don't know if you consider my HDDs as "external HDD" but I download and store all the marketplace projects, my projects and the game engine itself on them.

avatar image Jacky Jul 22 '14 at 01:10 AM

Ok, remove those USB keys and see if you still get the same error. And make sure you click on the storage icon near the clock and pick Safely Remove USB(I dont know what it is in French) before you unplug them.

avatar image WBS_PRO Jul 22 '14 at 01:42 AM

I just tested and it doesn't change anything, same error message :/

avatar image Jacky Jul 22 '14 at 02:09 AM

Hmm. Have you scanned your computer for viruses and spyware lately? I find a ton of different causes/solutions to this problem with a Google search but i wont be suggesting any of them just yet. So let your antivirus do a scan first and then we'll see what happens.

avatar image Mewbits Jan 23 '17 at 03:16 PM

I'm having this same problem and I do not have a USB plugged in.

When running the game, it says no disk in drive. I click continue. A dark window pops up, then it closes and no disk in drive pops up again. I click continue, and an Unreal Engine Editor has crashed dialog pops up.

I do have virtual clone drive so that I can run ISO files (my laptop computer doesn't have a physical CD drive).

Edit: It turns out that I had an old version of UE4 on my laptop. But I would like it to run on a computer without the editor. I cannot find the "Shipping" option others have talked about.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

No viruses whatsoever detected on my computer (I'm really careful about it don't worry).

EDIT: I think I found the source of the error message, I looked up in the task manager to see which process is relied to the error message and I found that it's called "csrss.exe" that stands for "client/server run-time subsystem", didn't know what that really mean or what is the relationship with my error message but by searching deeply on the internet I found that someone has some equivalent problem with some software that he just installed on his computer and the problem was related to an external device that is a "multi-format card reader" that can be used to read SD cards etc...by pluggin them into this device that is plugged himself by a USB port in the computer. So I just tried tu unplugg this device that I'm not currently using and it seems that the error don't show up anymore, I'll see tomorrow when I'll restart my computer if it really was the correct source of the problem.

EDIT 2: For those who might be interrested in which device it is and may have the same problem, my device is a "Realtek Semiconductor Corp. RTS5111 Card Reader Controller (USB2.0-CRW)"

EDIT 3: I just tried to replug my device and I actually get the same kind of error with the one change that it's not


anymore but


I assume that the " DR** " thing is random. So, problem solved !

Thanks for your help Jacky =)

more ▼

answered Jul 22 '14 at 11:57 AM

avatar image

46 3 4 24

avatar image ChrisTm Dec 07 '14 at 09:45 PM

Hi there ,

Just saying & for helping , that me too i solved this same error message in Unreal Engine 4.6 ;

There is no disk inside the disk player. Please insert a disk in the disk player \Device\Harddisk3\DR9.

Cause is my Android Tablet is connected to my computer. Voila , thank you

avatar image Ashh111 Jan 03 '17 at 12:39 PM

I can confirm this. Removing my external USB hub solved the issue for me. Thanks!

avatar image ARCoded Jan 27 '17 at 07:08 PM

I has the error since long time ago, Fl4sHNoX is right, i have a multi-format card reader. So the fact is confirmed.

Thank you!

avatar image fma_viz Jul 13 '17 at 08:36 PM

You rock for posting this. This issue was making me crazy. Thanks again!

avatar image EHX-X Dec 22 '17 at 10:28 AM

Note that the multi card format reader can also cause this issue if it isn't external. Had the very same issue on a laptop with built-in SD slot, and had to go into the device manager and disable "Drives/Generic- Multi-Card USB Device" to make UE4 work.

Since it's still a thing in UE4.15, it doesn't seem to be very related to UE4 indeed, however most programs work just fine. I wonder what makes the difference...

avatar image Constantin Suman Jan 02 '18 at 11:12 AM

Can confirm that disabling the internal multi-flash-card reader in Device Manager solved this issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question