Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Holding CTRL has interfering functions that cause a crash

Unreal Engine 4.3, Windows 7 64 bit, EVGA GTX 680 superclock

CTRL + Left mouse button has 2 functions

  1. Movement constrained to 1 axis.

  2. Selecting multiple actors, vertices, faces .etc

These 2 functions interfere with each other when trying to select multiple vertices in geometry mode. When clicking several vertices (holding CTRL), UE4 will detect the slightest mouse movements and then move the selected vertices. This causes tremendous lag (I believe UE4 is trying to select and move actors at the same time) which can sometimes crash UE4. If the engine does not crash, undo (CTRL + Z) will sometimes crash the program as well.

What I'm wondering is if there is a way to turn off the option to constrain movement to one axis when holding CTRL. It's a feature that I do not use since there are easier/alternative ways of constraining movement to one axis.

Product Version: Not Selected
more ▼

asked Jul 22 '14 at 12:19 AM in Bug Reports

avatar image

26 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first


I went through the editor preferences for key bindings to see if there was something in there that could be disabled and when I couldn't find a solution I reached out to one of the developers to see if there was a way to disable this in the engine or even by manually editing some of the config files for that key binding.

At the moment any key bindings that are associated with the mouse buttons are hard coded and cannot be unbound, at least for right now. This will be considered for future releases.

As for the crash, I was not able to reproduce this, but it is known that BSPs can be finicky.

Can you provide some repro steps that cause this to happen in a new scene starting fresh? The easier it is to reproduce the easier it will be to track down and fix.

And since you are experiencing a crash, can you please provide us with the .LOG and .DMP files from your [project]\Saved\Logs folder. Additionally, you can please send us the CrashReportClient.log file located in C:\Program Files\Unreal Engine\4.0\Engine\Programs\CrashReportClient\Saved\Logs.

On a Mac, the logs are located in: /Users/UserName/Library/Logs/Unreal Engine/(project name)Editor/ The Library Folder is hidden by default. The easiest way to get to it is by having finder the active application and while holding Option Click Go in the Mac Menu Bar. This will expose Library.

Thank you!


more ▼

answered Jul 23 '14 at 06:26 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 101 878

avatar image madmax12ca Jul 25 '14 at 01:53 AM


Please find attached several .LOG files and .DMP files from some crash instances.

As for the CrashReportClient.log, the only one I could find was in the 4.2 folder and it's dated before these crashes happen. The \CrashReportClient\ folder does not exist in the 4.3 folder. (or elsewhere on the computer)

As for steps to replicate. (This is exactly what I did)

  1. Create a cylinder brush.

  2. Make it have a bunch of sides (60-80)

  3. Make it hollow. (I had 2300 outer radius, 2100 inner)

  4. Select the cylinder and go into geometry mode.

  5. Hold CTLR and select several vertices.

  6. Holding CTRL restricts movement to 1 dimension, clicking down on the mouse can cause selected vertices to attempt to move.

  7. If vertices move, hit CTRL+Z (twice).

The crash sometimes happens when UE4 is trying to move vertices if there are many selected. If it doesn't crash, CTRL+Z will sometimes cause a crash.

I have had to hit CTRL+Z twice because the vertices were moved and then the one I clicked is selected. When I hit CTRL+Z I get something like. 1. Undo Select Actor 2. Undo Move

In all cases, the movement causes extreme lag. I have a pretty solid rig, it shouldn't be experiencing 30+ seconds of lag sometimes. I believe UE 4 is trying to select and move simultaneously.

(NOTE: Snapping on/off makes a difference in the lag, and the amount of movement (obviously). Thus far my solution has been to set snapping really high so that the vertices don't move (because the snap is too far) but every time they "want to move" the program lags like crazy)

link text

max_ue4_3_crash.zip (217.8 kB)
avatar image Tim Hobson ♦♦ STAFF Jul 28 '14 at 08:43 PM


I wasn't able to get this to repro on my end unfortunately. I did submit the report with your crash logs and dmp along with all your information here for repro to help prevent this type of crash in the future.

Thank you for all the information you've provided! :)


(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question