x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender amature causes tangent errors

After much testing I've discovered a Blender armature causes normal errors. The object doesn't have to be animated; just by adding an armature this happens. The bent normals are showing through my baked normal map.

Initially I thought this was a bake error but I've managed to track it down.

Below are images of simple objects exported and baked from Substance Painter. You can tell by looking which one has an armature applied. alt text

In this image, all of these objects have an armature. They look hideous.

alt text

I would be very grateful for any help in understanding this issue. It's easy to replicate (just add an armature to a hard surface object).

Product Version: UE 4.18
Tags:
more ▼

asked Nov 22 '17 at 03:34 AM in Using UE4

avatar image

TooManyDemons
120 1 3 6

avatar image c4tnt Nov 22 '17 at 05:53 AM

Have you set "Import tangents" instead of "compute tangents" while importing a model (and have you exported tangents)?

avatar image TooManyDemons Nov 22 '17 at 02:18 PM

@c4tnt:

Yes :( All of the objects in the screenshots were exported and imported using the same parameters. That's the horrible truth.

you can test this yourself with a hard surface baked object (with only one smoothing group). Import the object into your scene and apply materials. It will look very good and correct.

Then make one that's weighted to an armature, and import that with the exact same parameters. Apply the same material. It will look very bad.

This isn't very noticeable with character models where there's a lot of geometry. But it's extremely noticeable if I wanted to animate a hard-surface object with optimized geometry.

I'm not sure what to do about this problem. I first encountered it trying to animate large moving parts on a scifi table. I was unable to get it to look correct.

avatar image c4tnt Nov 23 '17 at 03:54 PM

Could you try export\import with following settings (works fine with 4.17 but I have no installed 4.18 to test): alt textalt textalt textalt text

You need to triangulate your model before exporting from blender. Also you have to apply edge split modifiers before exporting to the Substance Painter and disable Average Normal before baking alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey, that worked!

alt text

The key option here was to import normals and tangents.

Though I'm not sure why this works... It doesn't make sense to me that an armature would make a difference here. Anyhow, thank you! I'm new to UE4 (coming from Unity) and was worried this was a bug I wouldn't get past. Very much appreciated!

more ▼

answered Nov 23 '17 at 08:35 PM

avatar image

TooManyDemons
120 1 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question