x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.18.1 Editor crash on migrated project

I do have a C++ project that I started back on 4.14 and migrated it through the versions without any major issues(Needed some Target*.cs changes and such but nothing that could not be dealt with).

Now I cannot migrate the project to 4.18.1.

 [2017.11.22-10.12.17:156][783]LogLinux: Error: appError called: Assertion failed: !F->GetSuperFunction() || (F->GetSuperFunction()->FunctionFlags&FUNC_NetFuncFlags) == (F->FunctionFlags&FUNC_NetFuncFlags) [File:/run/media/stastny/ext_ssd/UnrealEngine/Engine/Source/Runtime/CoreUObject/Private/UObject/Class.cpp] [Line: 3068] 
    
 Signal 11 caught.
 Malloc Size=131076 LargeMemoryPoolOffset=131092 

I have tried reproducing the issue but sadly I could not find a way to reliably do so.

I can open the project when I set the default editor map but when I try to open ANY blueprint class type item from the project(Includes Blueprint Actors, Blueprint Interfaces, Function Libraries, HUD, User Widget, UMG drag and drop operation, GameMode, PlayerState) the editor crashes with the same error. (from the logs https://gist.github.com/aknarts/bd0d12abbc63ff3836ca6aba75b58f28 )

Please note that this includes things from the starter content that I made no changes in.

As I am not able to reproduce this all I can do is offer my project to test things out. I am not proud of it but there is nothing secret in it or nothing that cannot be redistributed.

This Is an extension of this error report

Edit:

Doing bit of debugging on this. In case it was not super obvious it is crashing here: https://github.com/EpicGames/UnrealEngine/blob/release/Engine/Source/Runtime/CoreUObject/Private/UObject/Class.cpp#L3068

I disabled the check(crazy I know) and the project loaded OK, was playable networked stuff worked OK too.

Got bunch of errors with this:

 1001[2017.11.23-23.37.09:309][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:309][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading ../../../../../../../../home/user/Documents/Unreal Projects/Project 4.18/Content/Code/Maps/DefaultMap.umap.
 [2017.11.23-23.37.09:309][263]LoadErrors: Error: /Game/Code/Maps/DefaultMap : Can't find file for asset. /Script/EnvironmentQueryEditor
 1001[2017.11.23-23.37.09:310][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:310][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading ../../../../../../../../home/user/Documents/Unreal Projects/Project 4.18/Content/Code/Maps/DefaultMap.umap.
 1001[2017.11.23-23.37.09:310][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:310][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading ../../../../../../../../home/user/Documents/Unreal Projects/Project 4.18/Content/Code/Maps/DefaultMap.umap.
 1001[2017.11.23-23.37.09:310][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:310][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading ../../../../../../../../home/user/Documents/Unreal Projects/Project 4.18/Content/Code/Maps/DefaultMap.umap.
 1001[2017.11.23-23.37.09:540][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:540][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading ../../../../../../../../home/user/Documents/Unreal Projects/Project 4.18/Content/Code/Maps/DefaultMap.umap.
 1001[2017.11.23-23.37.09:545][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:545][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading NULL.
 1001[2017.11.23-23.37.09:545][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'
 1001[2017.11.23-23.37.09:545][263]LogLinker: Warning: Can't find file for asset '/Script/EnvironmentQueryEditor' while loading NULL.
 1001[2017.11.23-23.37.09:545][263]LogLinker: Warning: Can't find file '/Script/EnvironmentQueryEditor'

I did use EQS at some point so it was enabled in the original project. Not sure why it was not enabled After the migration to 4.18.

Product Version: UE 4.18
Tags:
more ▼

asked Nov 22 '17 at 12:36 PM in Bug Reports

avatar image

aknarts
489 8 10 14

avatar image aknarts Nov 23 '17 at 09:06 PM

Curious thing, when I migrate the code manually it sometimes does work(basically if it does not need to take along any dependency it works OK. I would say that the migration is somehow broken.

avatar image Thomas G ♦♦ STAFF Nov 29 '17 at 05:20 PM

Hello Aknarts,

I have a couple of questions about your issue to help narrow down the issue you are experiencing.

  1. What platform is this issue occurring to you on? is it happening on multiple platforms?

  2. Is your project using any version of source control?

  3. Can you provide the full callstack for the crash you are experiencing?

Thanks!

avatar image aknarts Nov 30 '17 at 09:47 AM

Hi, it is the same exact issue as https://answers.unrealengine.com/questions/718928/4180-editor-crash-while-opening-child-blueprint.html , there is a way how to reproduce it now. It is multiple platforms, I just find it easier to test it on Linux as I have to build the editor there anyway, but on the same project it happens on Windows too. Using Git for source control. And I think I provided the full callstack in the other bug report.

avatar image EoinOBroin Dec 07 '17 at 10:50 PM

I'm getting crashes on startup (at 93%) from a 4.18.0 source build project being migrated to 4.18.1 source build. Could this be the same issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello again,

It appears that fix has been submitted and should be in the 4.18.2 binary release. If you are compiling the engine yourself, here is the github pr.

Thanks!

more ▼

answered Dec 07 '17 at 09:55 PM

avatar image

Thomas G ♦♦ STAFF
7.6k 64 4 51

avatar image aknarts Dec 08 '17 at 11:28 AM

I can confirm that the issue is fixed on the current 4.18 branch (4.18.2)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Let's go for Launcher 4.18.2 hotfix !!! Make it a great weekend again!

more ▼

answered Dec 08 '17 at 11:34 AM

avatar image

VictorBurgos
2.3k 55 22 106

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question